1
$\begingroup$

I've never had issues with any blender version up through 2.8 64 bit and was actually using blender when i noticed that 2.81 was released. I downloaded 2.81a on Dec 5 and it opened for a few moments and then crashed. Since then i have been unable to get any version started up again with the exception of the 32 bit version of 2.8 (which I don't understand). I have tried absolutely every suggested fix on the internet.

I have a pretty beefy rig that i built for the purpose of modeling and gaming. GTX 1070, i7 7700k, etc... All drivers have been updated to no avail. Tried the opengl32 fix. when i copy to the folder i get an error saying i need a driver that supports opengl 3.3 but the most updated drivers i have support Opengl 4.6, so i dont think that is the issue.

Originally the command window that opens before blender said something about the userpref.blend in %appdata% and the internet said to delete that blender foundation folder and reinstall everything. Now, that userpref.blend message is gone but the program still doesn't open.

I've tried opening in cmd prompt with --debug and blender still crashes without throwing any error messages. "when i say crashes i mean window goes gray and i get the little (not responding) message".

Final thing i have noted, if i restart my computer and immediately open blender (i.e. within 30 seconds, any longer and it wont open at all.) blender 2.81a opens perfectly and quickly. but it seems to crash as soon as i either click away from blender, or open another window in blender like the preferences menu. Still no error messages.

I found a similar question on here that said to link debug and system files created from blender_debug_log.cmd. The steps leading to the creation of the file. was

  1. restart computer
  2. immediately open blender_debug_log.cmd
  3. open preferences ( but again any window in/out of blender produces same result)
  4. window goes gray and shows not responding.

Here is the google drive link: https://drive.google.com/open?id=1fNBgJAKFsnpymMCqLeAe69RDLn51kNKE

$\endgroup$
  • $\begingroup$ Does this answer your question? Blender 2.8 causes all other versions to not run! $\endgroup$ – Moog Dec 13 '19 at 3:09
  • $\begingroup$ Thank you for adding the debug logs and writing a detailed question. Unfortunately the debug logs look fine, there are no errors reported and drivers are already the most recent version. Since Blender doesn't really crash, but freezes/hangs have you tried keeping it open for a while? Does it respond some time later? I noticed that you've stored your Blender install in the OneDrive directory, perhaps you could try putting it somewhere else on your system (just a wild guess in case there is some conflict happening with One Drive getting a file lock and Blender can't access its own files). $\endgroup$ – Robert Gützkow Dec 13 '19 at 10:44
  • $\begingroup$ Thanks for the quick responses. I apologize for responding late wasnt expecting answers so quickly. That other post did not help. But did give me the suggestion to post the logs here. For the other questions. I have left it open for hours (1 hr to all night) at a time to see if it unfreezes. No dice... I did notice that it was in one drive. I have tried it in folders that arent linked to one drive as well as storing the zip/unzipped folders in two different hard drives. One ssd and one hdd. That didnt help either. $\endgroup$ – Donnie Petersen Dec 13 '19 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.