3
$\begingroup$

I have created two bezier circles, then converted them to meshes. When I press tab to enter edit mode, the objects appear completely black.

You can see the exact tutorial I am following at 6:20 of this video

Why do they appear black, and not have any subdivisions? Is this a problem with blender, or is there a setting I need to change?

Edit Mode
enter image description here

Edit Mode + Wireframe view enter image description here

$\endgroup$
  • $\begingroup$ Are you sure you remembered to convert the Bezier curves to meshes? $\endgroup$ – brasshat Sep 22 '14 at 7:31
8
$\begingroup$

From what i can see in the image your object has about 166000 Vertices. In Edit Mode vertices are displayed in a certain size independent from the polygon size, so it may well be that you only see the black vertices, while all edges are hidden because of the vertex "display size". Here is an example with 4 rings of increasing vertex density:

enter image description here

Also none of your vertices is selected right now, so this would explain why the mesh appears in black. So i guess when you hit A then your rings will turn from black to light orange (the color of selected vertices)

Maybe you had added a subdivision modifier to your Curve ? When converting your curve to a mesh the subdivision modifier would be applied...

$\endgroup$
  • $\begingroup$ That's a good a pretty good guess Gaia, I thought that maybe he had a default black texture assigned. 166000 vertices, I suspect you are correct. $\endgroup$ – MarcClintDion Sep 24 '14 at 0:00
  • $\begingroup$ you are correct I had the same issue. I was creating a landscape and then added a subdivision and from then on it was black. When it came to baking my textures it wouldn't work. When I press A it does turn into orange color which is what I'm use to, but I'm not sure if that will solve the issue $\endgroup$ – user16804 Aug 30 '15 at 22:41
0
$\begingroup$

Sorry for threadmancy but this may help people in future. There's a possibility that blender has flipped the lighting of those objects. if you select all of the vertices of the objects and then go into Mesh>normals> and try recalculating outside. If that doesn't work go into Mesh>normals> recalculate inside. This is how i solved a similar issue i had. good luck.

$\endgroup$
-1
$\begingroup$

What fixed this issue for me is: Material>shading> enable the checkbox that

$\endgroup$
  • $\begingroup$ Incomplete answer. $\endgroup$ – Lukasz-40sth Jun 10 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.