1
$\begingroup$

I use cycles GPU. My light source is at left but the shadow also at the left. I think that the point light did'nt work and it uses scene light. I try to tick on the scene world under viewport shading and it turn all dark. I even don't understand the lighting option under the viewport shading. And when I render, the picture is darker than preview. Thanks for your help!

After rendered

$\endgroup$
2
$\begingroup$

The second screenshot shows a correct preview, since Scene Lights and Scene World are enabled. If Scene World is disabled, an HDRI is used to light the scene preview. With Scene Lights off, your point light is ignored, hence the wrong shadow. The options are explained in the manual.

Scene Lights

Use the lights in the scene when rendering the scene.

Scene World

Use the world of the scene when rendering the scene. When turned off a world will be constructed with the next options.

  • HDRI Environment

    The environment map used to light the scene.

  • Rotation

    The rotation of the environment on the Z axis.

  • Strength

    Light intensity of the environment.

  • Background

    The opacity level of a very blurred version of > the HDRI will be rendered as background in the 3D View.

$\endgroup$
6
  • $\begingroup$ If you want to modify the actual world settings used for the final render, then you will have to go to the World Properties or use the node editor. $\endgroup$ – Robert Gützkow Dec 12 '19 at 14:33
  • $\begingroup$ If I turn on or turn off the scene light, the shadow still at its place (left side) even tough the point light at the left side. I think no change when I turn on or off the scene light. The change is at the scene world only, it becomes dark when turned on. $\endgroup$ – Aziz Akmal Dec 12 '19 at 14:54
  • $\begingroup$ Both need to be enabled in order to give you an accurate preview for your final render. It's dark because you only have a point light in your scene and your world has the default grey color. You can add an HDRI to the world which will be used in the final render, however that has to be configured in the world tab or in the node editor, not in the viewport settings. You could also add other lights, like a sun, point, spot or area light and setup a three point lighting. $\endgroup$ – Robert Gützkow Dec 12 '19 at 14:59
  • $\begingroup$ The incorrect shadow with Scene World off is caused by the HDRI that is loaded (as shown in your first screenshot). The light direction for it apparently comes from an opposite direction, but since it's much stronger than your point light, it still casts a shadow (despite your point light being there). If you adjust the rotation slider, the shadow should move. $\endgroup$ – Robert Gützkow Dec 12 '19 at 15:06
  • $\begingroup$ okay thank you. Really appreciate that! $\endgroup$ – Aziz Akmal Dec 12 '19 at 15:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.