1
$\begingroup$

What am I doing wrong? Using 2.81 Windows 10. Onion skins do not appear in draw mode, but they do appear in edit and sculpt. When I load the same file into 2.80 the onion skins appear in draw mode.

As you can see (top image) Onion Skins are checked in Viewport Overlay, and the layer (Mr C) also has onion skins checked, so too are they checked in the materials tab.

And in Blender 2.80 opening the same file (bottom image) the onion skins show.

When I open up a new blank file in 2.81 and draw with grease pencil the onion skin works fine in draw mode.

Here's the .blend file

Thanks.

enter image description here enter image description here

$\endgroup$
1
$\begingroup$

I want to promote this as I have a similar issue, except that in no modes can I see the next and previous frames for my main Stroke. If I create a new Grease Stroke, then it works as expected. I believe all the required onion skinning options are also selected.

My Blend file is


Answer 2 For my issue, as suggested by Maitrisingh, was that the Material Properties also needed to have onion skin selected.

Answer 1 For the original issue, try this: Only have the one 3D viewport open (may be a bug having 2 open), go to Sculpt and then go back to Draw and it then started to work for me. Hope this works for you.

enter image description here


| improve this answer | |
$\endgroup$
  • $\begingroup$ The reason your onion skins don't show is that you have some onion skins unchecked: Look in the Object Data Property tab, where 3 of the 4 layers have onion skins unchecked (Body, Arm & Hand and Eyes Fill are unchecked. Only Head is checked). And in the Material Properties tab, your Lines and Eyes are both unchecked. :) $\endgroup$ – Maitrisingha Dec 13 '19 at 20:23
  • 1
    $\begingroup$ Thanks @Maitrisingha - The Materials Properties was the problem for me. $\endgroup$ – Derrick Dec 14 '19 at 7:29
  • $\begingroup$ Hooray! Thanks Derrick. I shouted out loud when it worked. And if I then reopen a second viewport window it still works. Glad we could help each other across such a distance! ;) $\endgroup$ – Maitrisingha Dec 14 '19 at 13:01
1
$\begingroup$

I realize this is an older question, but I found this while having the same issue. I discovered that for me the problem was that I was in the render preview viewport shading mode. Onion skinning worked in ever viewport shading mode except that one. Hopefully that helps someone else.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.