1
$\begingroup$

I'm trying to render an image with an output that is the pure diffuse colour only. In earlier versions of Blender I would have just used the internal renderer and created emission materials. But, in 2.8 with Cycles or Eevee, there is always a slight noise on the image.

In the viewport with viewport shading, it gives the result I'm after. Viewport Screenshot

With the default Eevee samples I get this result with soft edges and a noise in the flat colours. Eevee Render Default Samples

If I set Eevee's samples to 1 I get clean edges, but still a subtle noise in the flat colours. Eevee 1 Sample

I know the noise is very subtle, but I need it to be a solid colour. I was hoping I could use the compositor to get just the diffuse, but I couldn't figure out how. I still ended up with the noise in the result.

Thanks for your help Dan

$\endgroup$
  • 1
    $\begingroup$ If you want flat uniform colors perhaps the workbench engine is more suitable for this task? Otherwise set the Filter Size to zero in Render Properties > Film, disable dithering in Output Properties > Post Processing and save the image in a format that supports lossless compression (to avoid compression artifacts). $\endgroup$ – Robert Gützkow Dec 11 '19 at 11:14
  • $\begingroup$ @RobertGützkow Yes, it was the post processing dithering that was the issue. Thanks for your input. $\endgroup$ – DanMarionette Dec 11 '19 at 11:27
0
$\begingroup$

Hello and welcome bro!

I suppose the thing is post processing noise dither from Properties > Output

  1. Dither intensity = 1: Dither intensity = 1

  2. Dither intensity = 0: Dither intensity = 0

  3. Dither intensity = 2: Dither intensity = 2:

| improve this answer | |
$\endgroup$
  • $\begingroup$ This is spot on. I thought I was going mad. What was really throwing me is that if you right click on the rendered result to sample the image colours, they don't change across the noise! If I saved it, however, and sampled the colours in an external app it showed the different colours. Anyway, thanks for your help and thank you for the kind welcome. $\endgroup$ – DanMarionette Dec 11 '19 at 11:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.