0
$\begingroup$

I have a simple character that I have rigged with an armature and created a Walk animation. I am very much in the learning-phase of how to do this.

I have exported the scene as a glTF so I can import into Three.js. However, when I do so, the Walk animation only appears to apply to some of the bones.

I have imported the model into glTF Viewer where I see the same issue. This suggests the problem is somewhere on my blender model and/or how I'm exporting it.

Here is how the walk cycle appears in Blender. Animated gif: http://g.recordit.co/iTbXdeNprB.gif

enter image description here

Here is how the model appears in glTF Viewer. The arms-out-wide is the armature's default pose. Animated gif: http://g.recordit.co/sgaKQBFXqc.gif

enter image description here

I am hoping someone can point to the obvious mistake I've made. I have used the default options in the glTF exporter - I can't see anything obvious in there.

$\endgroup$
0
$\begingroup$

I should have mentioned this was using Blender 2.80. Some further digging found this issue on the exporter: https://github.com/KhronosGroup/glTF-Blender-IO/issues/439

Having upgraded to Blender 2.81, which includes the fix for this issue, my model now imports correctly with the animation as I expected.

$\endgroup$
  • $\begingroup$ ^You may want to mark your answer as accepted here. :) $\endgroup$ – Don McCurdy Dec 27 '19 at 1:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.