0
$\begingroup$

So trying to get this wolf I did finished but I can't paint on it as it keeps saying missing uv things! Any help please with this? enter image description here

$\endgroup$
0
$\begingroup$

In order to paint on a 3d object,first Uv maps and paint/texture layers need to be created and saved and only then one can paint on it.There are many other ways to do this but the one below, is by far the simplest.

I am demonstrating the procedure on this monkey ,you can follow the same steps on for your model.

1 .After creating/adding monkey in object mode, select the monkey and switch to texture mode.Also open a side window and open the Uv/Image editor.
2 . Once in texture mode -tools panel(T),click on add simple Uv's button.This will create a Uv map of the object in Uv/Image editor. Save this Uv map as a Png on your computer by clicking Image->New Image->Create 1024x1024 png.
3.Going back to 3dview,click on Paint Slot dropdown menu and select the type of Paint Slot you want.For general purpose,DiffuseColor =1024x1024 should suffice .
enter image description here

4.Save these newly created Uv map and Paint Slot/layer as a Png Image by going to the Uv/Image editor ->Image->Save as Image.This is done by individually selecting the Uv map and Paint layer from the Dropdown menu.
enter image description here

5.Start Painting by going to the texture paint -tools panel and under brushes selecting the TexDraw brush and the required color. enter image description here

6.IMPORTANT -Save the Paint layer frequently as Blender does not Autosave.

$\endgroup$
  • $\begingroup$ That's different from my blender $\endgroup$ – Gamzee wolf Dec 8 '19 at 20:28
  • $\begingroup$ Even if Blender version's are different ,the procedure is the SAME.Simply go to textures panel (top) with your model selected and follow the above steps.You should be able to get the above shown results. $\endgroup$ – starzar Dec 9 '19 at 5:12
0
$\begingroup$

To texture paint, you need to set up a material, an image texture, and a UV map.

enter image description here

To make Ctrl+T work Node Wrangler add-on should be enabled.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.