2
$\begingroup$

I have a transparent image that I created as a plane and I can't seem to get it to be transparent. I've saved the PNG with the color and alpha data and it still not transparent even with the nodes connected. I am using Blender 2.81 please help!

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ Your Color Space is also set to sRGB OETF, which was never designed for rendering. Can you set it to sRGB at all? $\endgroup$ – ᴊᴀᴄʜʏᴍ ᴍɪᴄʜᴀʟ Dec 8 '19 at 10:46
  • $\begingroup$ @vklidu A little OT, but isn't that Brno main railway station in your image? $\endgroup$ – ᴊᴀᴄʜʏᴍ ᴍɪᴄʜᴀʟ Dec 8 '19 at 10:53
  • $\begingroup$ Could this be something with Windows? When I save the image and view it in Windows it doesn't show it to be transparent. Is there a way I can share this png with you guys? $\endgroup$ – shillman1 Dec 8 '19 at 16:14
  • $\begingroup$ A bit late now you have solved the issue, but you edit the question and use the image button to upload the image to imgur. $\endgroup$ – Moog Dec 8 '19 at 16:30
2
$\begingroup$

You have to change the Blend Mode in the material settings and have to be in Rendered View.

blend mode

Any of Alpha Clip, Alpha Hashed or Alpha Blend would work for a single image, but for a pixel perfect preview in EEVEE, Alpha Blend is required.

Alpha Blending
Use alpha blending to overlay the surface color on top of the previous color.

$\endgroup$
  • $\begingroup$ but he is using Alpha Blend type ... $\endgroup$ – vklidu Dec 8 '19 at 9:56
  • $\begingroup$ You're right. Perhaps they are not in rendered view, or the image has no alpha. $\endgroup$ – Leander Dec 8 '19 at 10:00
  • $\begingroup$ Yes I have tried all those options, I still get no transparency. $\endgroup$ – shillman1 Dec 8 '19 at 15:30
1
$\begingroup$

I figured it out!

When I was saving the transparent image I didn't have the output file include the alpha data, so when I enabled RGBA the image was then transparent.

enter image description here

$\endgroup$
  • $\begingroup$ Tip: Don't use PNG. It's a broken cancerous format. $\endgroup$ – troy_s Dec 9 '19 at 0:13
-2
$\begingroup$

You need to mix with a transparent shader and use image alpha as the mix factor.

$\endgroup$
  • $\begingroup$ I've tried this and it has the same issue. $\endgroup$ – shillman1 Dec 8 '19 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.