0
$\begingroup$

I'm trying to get root motion to work with my Blender character. The issue is that the character keeps lunging backwards, since for some reason whichever bone I pick to be the root node is delayed as you see in the transform. (https://media.giphy.com/media/MczFKgE17JI7LZPQqj/giphy.gif)

I believe the problem is Rigify. I followed this great tutorial based on an older version of Blender (https://youtu.be/SsHCkK4iou0). But I still hit this issue, with and noticed some differences. The nodes that show up are different and mostly missing. Changing to humanoid does not work since the 'head' is missing which is not the case. And the biggest difference is the lunging backwards.

I created a simple 4 bone rig with the cube as seen in the gif and that moved with the root motion, so I am not sure why I am getting issues with the character. I've tried different methods of FBX export and no results yet. If anyone was able to use Rigify with Unity/Root Motion, I would really appreciate the help! Thanks.

$\endgroup$
  • $\begingroup$ I found out the solution and it was how rigify creates the bones. You just have to set the parent of ORG-Spine to DEF-Spine. I created a video showing the process for anyone that needs more info. youtu.be/E-Dg_Z3pLXk $\endgroup$ – Sebastian Alvarez Dec 9 '19 at 18:52
0
$\begingroup$

The problem is that ORG-Spine and DEF-Spine should be together. Click on ORG-Spine and under its bone settings - Relations- Set the parent to DEF-Spine. Now you can import it into Unity without any problems.

Setting the ORG-Spine

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.