5
$\begingroup$

I work with Blender 2.81a and I have a problem with some artifacts in the shadows of objects with smooth shading. Based on the release note of Blender 2.81 ,(https://www.blender.org/download/releases/2-81/), I expected this problem to be solved. There’s a note with a comparative screenshot saying: “Reduced shadow terminator artifacts for bump mapping with diffuse BSDFs.“

There’s no detail about the issue. There’s a mention about “bump mapping”. I have another scene with bump mapping and the problem is the same as in my test shown below. Here’s a screenshot of my test below.

The only solution right now is to increase of the number of polygons with a “Subdivision Surface” modifier. However that makes a crazy amount of polygons and the modifier cannot fit all situations.

Another element of solution is about the light. I noticed that happens particularly when there’s one directional light in the scene like a sun light. Increasing the “Angle” parameter creates a smoother effect. Too much of this becomes blurry and unrealistic. My screenshot shows a sun with the angle 6.4 degrees.

These artifacts only happen in Cycles. Eevee seems to be correct.

I expected this problem to be solved. However it is still present. Am I missing something?

enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ yes it was supposed to be solved, maybe in the next versions? And yes, the solution seems to be increasing the light size ("Angle" in 2.8) $\endgroup$
    – moonboots
    Dec 8 '19 at 11:38
8
$\begingroup$

Edit 2021-11-26: a better solution is available as of Blender 3.0, added to the answer below.

Blender 3.0+

A setting called Geometry offset is enabled by default, hence the artifact should not occur anymore.

The geometry offset value can be tweaked in the object properties Object Properties \ Shading \ Shadow Terminator.

Geometry offset preserves the shadow's location and color, unlike Shading offset (previously called Shadow terminator offset in Blender 2.9).

Further details in this video.

Blender 2.9.x

In blender 2.9, a Shadow terminator offset parameter has been added under Object Properties \ Shading. It is set to 0 by default, increasing its value fixes the problem.

Demo and explanations in this video.

Earlier blender versions

The artifact disappears when adding more geometry, either by subdividing the mesh, or adding a subsurf modifier.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.