3
$\begingroup$

I am trying to texture paint onto a mesh with a lot of sharp edges and tips. These areas do not seem to register with the painting, which creates artifacts. I have tried using different UV unwrapping methods and pretty much ever brush settings I can think of, but it doesn't help. Why does this happen, and how do I fix it?

enter image description here

$\endgroup$
  • $\begingroup$ maybe try to increase a bit the brush bleed value in the N panel > Tools > Options? $\endgroup$ – moonboots Dec 6 '19 at 10:15
  • $\begingroup$ You could paint directly in the image editor, or just clean up that messy topology. $\endgroup$ – Arthur Blaquart Dec 6 '19 at 14:21
  • $\begingroup$ Bleed value doesn't make any difference. Painting in the editor isn't really viable. The topology is supposed to be sharp in these areas. It's not really messy, just complex. $\endgroup$ – Drudge Dec 6 '19 at 19:39
  • 1
    $\begingroup$ Can you share more screen shots of exactly what conditions this is in, like what your UV map looks like, what your brush settings are, what your subsurface modifier is set to if at all, what edge crease you have set, and if you have tried face selection masking yet to drop color with the fill tool in a controlled way? $\endgroup$ – Craig D Jones Dec 9 '19 at 18:46
  • $\begingroup$ this could be an issue of uv layout.. try to check if your layout have large enough area and that they are big enough and not overlapping maybe.. $\endgroup$ – four two Dec 13 '19 at 11:54
0
$\begingroup$

Turn off backface culling in the options of your brush in paint mode. enter image description here

$\endgroup$
  • $\begingroup$ Have tried it, no luck! Have also tried disabling falloff, and multiple different UV unwraps some of which had seams on these edges, and some don't. Also tried without subsurf. $\endgroup$ – Drudge Dec 11 '19 at 7:01
  • $\begingroup$ please share the blend file of the problematic area. $\endgroup$ – Mobin Dec 11 '19 at 7:03
0
$\begingroup$

After playing with the UV maps more, I have found that the problem went away if I didn't allow Seams/UV edges in those areas. I had thought I had ruled this out, but I had used too low of an angle on my Smart UV unwrap, and so had still ended up with an edge in those areas even though it wasn't marked as a seam.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.