3
$\begingroup$

I'm creating an animation where I rotate an object, insert a LocRotScale keyframe (via the I key), select another frame, rotate the object again and insert a LocRotScale keyframe.

For example I use this:

Z, 190, Enter

Now I want to rotate the object around its own z-axis instead of the global z-axis. I've found out if you press the [Z] two times you get the Local axis instead of Global.

For example I do this now:

ZZ, 190, Enter

The rotation is ok, but when I insert the LocRotScale keyframe it did the rotation, but not around the Normal axis, but it used the Global axis.

Any suggestion on what I'm doing wrong here?

$\endgroup$
0

1 Answer 1

5
$\begingroup$

Set Rotation type to ZXY Euler, then the animation around the local axes works like a charm.

enter image description here

Here is an Example Blend File for inspection: http://www.pasteall.org/blend/31685

$\endgroup$
4
  • $\begingroup$ I've tried that already. Looks like the same problem: blender.stackexchange.com/questions/12211/… (see the YouTube video in the post) In the comments they suggest to create an empty. Where can this be found? $\endgroup$
    – juFo
    Sep 19, 2014 at 13:06
  • $\begingroup$ I added my example Blend file to my answer. Unless i misunderstood your issue completely it works as i described it. $\endgroup$
    – Gaia Clary
    Sep 19, 2014 at 13:29
  • $\begingroup$ It works indeed, but I had Local enabled instead of Global, which gave me another output. wish this was easier in Blender. $\endgroup$
    – juFo
    Sep 19, 2014 at 14:11
  • $\begingroup$ Funny that this is the simplest way in all of the google results and YouTube vids. Did you even have YouTube back in 2014? :P Most want to use a constraint or parent to empty. I couldn't figure those out. 2022 Rep'yo'city $\endgroup$
    – The Way
    Aug 2, 2022 at 16:42

Not the answer you're looking for? Browse other questions tagged .