25
$\begingroup$

Can Blender export to the COLLADA format?

I tried going to File → Export, but COLLADA was not an option.

I'm using Blender 2.66.1 on Ubuntu 13.04.

$\endgroup$
  • $\begingroup$ Interesting. Should be there. It's the first option for me. Blender 2.67a $\endgroup$ – Daniel Pendergast May 23 '13 at 14:44
  • $\begingroup$ Can you try this on the latest version and update your answer? Where did you install Blender from? The Irie PPA? $\endgroup$ – A Wild RolandiXor May 23 '13 at 14:54
  • $\begingroup$ Yes, it can. Make sure you're using blender official from blender.org $\endgroup$ – aditia May 23 '13 at 14:57
  • $\begingroup$ Are you sure that you went to the 'export' menu and not 'save as'? I also saw "Collada (Default) (.dae)" as my first option. Blender 2.66a $\endgroup$ – Gwen May 23 '13 at 14:59
  • $\begingroup$ As @aditia mentions, official builds (blender.org) have COLLADA option enabled by default. If you get builds from other locations (apt sources, graphicall.org, other linux distros) you might get one that doesn't have it turned on. $\endgroup$ – jesterKing May 23 '13 at 22:04
19
$\begingroup$

I use Blender builds from the irie PPA, and I have it by default:

enter image description here

Installing from the PPA:

  • Add the PPA: ppa:irie/blender (sudo add-apt-repository ppa:irie/blender)
  • Update your sources (Ubuntu Software Center does this automatically, but you will need to do it manually if adding from the command line). (sudo apt-get update)
  • Install blender (this package is 2.6x from git) (sudo apt-get install blender)

More info: https://askubuntu.com/questions/169542/how-do-i-install-the-latest-blender-3d-builds-from-a-ppa


Collada support is enabled and available in these builds.

$\endgroup$
  • $\begingroup$ Thank you! I was using the default provided in the Ubuntu Software Center. With the version from the irie PPA, everything works. $\endgroup$ – Inkbug May 23 '13 at 16:30
  • $\begingroup$ I wasn't sure you wanted commandline stuff, but I see you added it ;) $\endgroup$ – A Wild RolandiXor May 23 '13 at 16:43
6
$\begingroup$

Your build probably wasn't compiled with COLLADA support, otherwise it should be there.

Try grabbing a build from here

and make sure it has WITH_OPENCOLLADA ON

or make sure you download an official release from the official site.

$\endgroup$
3
$\begingroup$

Collada file export should come with Blender 2.66a. However, if it isn't installed, there are a number of external plug-ins you can use to get full-featured Collada compatibility.

The best one of these you can download from http://sourceforge.net/projects/colladablender/.

If that doesn't work for you, you can always try exporting to one of the other file type options, and then using an external program to import/convert into a Collada file.

====

Please note: the above link points to a blender 2.49 script. it will not work with recent Blender versions!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.