0
$\begingroup$

I'm hoping I don't have to start over, but I am pretty new to blender and I am not sure if I set up the rig correctly. I have been unable to find a solution, or the proper set up for objects that move based on an IK arm in Unity. I tried baking the animations but that did not work either. Any ideas how I can fix this? Thanks.

How it looks in Blender

How It looks in Unity

$\endgroup$
0
$\begingroup$

the local transforms are not 0 apply the local transforms. you can do that in unity of blender. in blender just use alt + r for zeroing rotation (or alt +g for move and alt+s for scale) if you need to apply them use ctrl + a and select accordingly.

you might need to adjust your transform after doing so, so I recommend using some placeholders first.

$\endgroup$
  • $\begingroup$ Thanks, This worked in Unity. How can I set up the rig to avoid this in Blender, because I was not able to get it to work from Blender to Unity. Do I animate first, than Zero out? Do I zero out before animating? $\endgroup$ – Sebastian Alvarez Dec 4 '19 at 14:45
  • $\begingroup$ make sure everything is zeroed in blender. also there are options in export and import. make sure the both are correctly set and in unity set them up correctly $\endgroup$ – Mobin Dec 4 '19 at 15:51
  • $\begingroup$ I zeroed everything and it still moves when importing to unity. Best place to find the options online? Videos I see just bring in the blender file and it works, so I'm not sure what the issue is. $\endgroup$ – Sebastian Alvarez Dec 4 '19 at 17:49
  • 1
    $\begingroup$ Edit: I found that everything has to be done in the rest position first before animating. Thanks. $\endgroup$ – Sebastian Alvarez Dec 4 '19 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.