2
$\begingroup$

I have imported a large model with lots (hundreds?) of objects. The hierarchy of the model is not very logical so I am trying to fix this.

Therefore I would like to select objects in the viewport to group them. But when I click (trying both the Tweak and Select box tools), nothing gets selected. When I select an object in the Outliner, it selects (and outlines) perfectly fine. Selecting everything through the outliner is not an option as the object names are the same: group_nnnn (nnnn being a number)

I have tried switching from 'Layout' to 'Modelling' as I read somewhere here, but switching leaves me with an empty viewport.

What am I missing here?

enter image description here

Edit: added a screenshot

Non-empty empties??

enter image description here

With selectables on and empties unchecked:

enter image description here

$\endgroup$
  • $\begingroup$ Can you add a screenshot of the whole user interface? Perhaps you've disabled the overlay or something similar. $\endgroup$ – Robert Gützkow Dec 3 '19 at 12:45
  • $\begingroup$ sure, i have added it $\endgroup$ – RogueSheep Dec 3 '19 at 13:15
  • $\begingroup$ You're currently in edit mode. Switch to object mode and you should be able to select them properly. $\endgroup$ – Robert Gützkow Dec 3 '19 at 13:59
  • $\begingroup$ You are right there @RobertGützkow, unforunately switching to object mode does not make selecting objects possible either. A and Alt-A do work properly as does 'Select Pattern'. $\endgroup$ – RogueSheep Dec 3 '19 at 14:39
0
$\begingroup$

Hmm ... that's a lot of empties in the outliner ... let's hide them, uncheck empties

Also make sure that objects are selectable, enable Selectable in the restriction toggles - the one that looks like a paper airplane.

Outliner options

If you have checked that the objects are selectable then you need to check the View Object Types Menu has Mesh selection enabled:

View Object Types Menu

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks Moog, but empties is unchecked and even with Selectable selected I am still not able to select in the viewport. Strange thing: when I do check empties, the empties open up and have empties inside? (added a screenshot in the first post) $\endgroup$ – RogueSheep Dec 3 '19 at 21:33
  • $\begingroup$ Thanks for thinking along @Moog! In 'Object Types Visibility' it's all eyes and arrows. I have added a screenshot of the outliner. $\endgroup$ – RogueSheep Dec 4 '19 at 7:40
  • $\begingroup$ I am willing to send this file it that would help, please dm me if that would be an option. $\endgroup$ – RogueSheep Dec 4 '19 at 7:47
  • $\begingroup$ Tried uploading there but I can't see any results... $\endgroup$ – RogueSheep Dec 4 '19 at 17:22
  • $\begingroup$ It's just under 150Mb, no code showed up and no error message either. I have even tried a different browser to upload..Seems software-mysteries are haunting me... I could WeTransfer it or zip -and-mail (yes, getting desperate here ;-) $\endgroup$ – RogueSheep Dec 4 '19 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.