1
$\begingroup$

I have been fiddling around with the LuxCoreRender rendering settings, but both denoisers do not seem to be having effect on my frames that I have rendered.

I have re-installed LuxCoreRender multiple times, and used the default settings + my own custom settings to try to get it to work, but for some reason it will not. The viewport denoiser is working perfectly, however. Also, if I set the denoiser settings to be heavier on denoising, Blender will quit, running out of memory.

Q: Is there some way I can use the same settings for the viewport rendered view, and somehow apply them to the rendered frame settings?

$\endgroup$
  • 2
    $\begingroup$ When viewing the render make sure the dropdown on the top right of the Image Viewer is set to the correct pass. You can also render to exr multilayer to get both passes (denoised and beauty) in one file for comp. $\endgroup$ – brockmann Dec 22 '19 at 1:20
  • 1
    $\begingroup$ Nope, was a comment to this question (before you changed title and the whole content blender.stackexchange.com/posts/159746/revisions) I'd suggest ask a new one. $\endgroup$ – brockmann Dec 22 '19 at 1:31
  • $\begingroup$ Does it save the rendering as the image editor view type then? Because I rendered a luxcore animation, and it was not denoised. $\endgroup$ – Nate_Sycro27 Dec 22 '19 at 1:43
  • $\begingroup$ Your settings worked by the way, thank you. $\endgroup$ – Nate_Sycro27 Dec 22 '19 at 1:44
3
$\begingroup$

Make sure the dropdown on the top right of the Image Viewer is set to the correct pass (DENOISED):

enter image description here

I'd suggest render to OpenEXR Multilayer to get both passes (beauty and denoised) in one file for comp:

enter image description here

Alternatively you can add a Render Layer node in the Compositor to get the DENOISED socket and connect both passes to a File Output node or even blend between both passes before saving:

enter image description here

Note: The Composite Node has only one input socket so this approach does not store any raw data.

$\endgroup$
  • $\begingroup$ Thank you, this fixed m problem. $\endgroup$ – Nate_Sycro27 Dec 22 '19 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.