1
$\begingroup$

I was messing with UV unwrapping, and this is what happened:

The after

I reset the UV map, but to no result. For reference, I have older render of the same glass (the version which was unfortunately overwritten):

enter image description here

How to make it smooth again?

It looks like there are two faces in the same place oriented other ways. That's how face orientation view looks like: How to rotate these faces?

Face orientation

$\endgroup$
  • $\begingroup$ Could it be that your texture is using something other than the UV coordinates? Check your material nodes and disconnect the condensation texture to check if the issue is caused by the material. $\endgroup$ – Robert Gützkow Nov 30 '19 at 19:14
  • $\begingroup$ The problem is... that I don't use any texture. I only messed with UV unwrapping, nothing with textures. $\endgroup$ – P4wlos222 Nov 30 '19 at 19:17
  • $\begingroup$ It's strange, because the plate has same linked material as cup, but it is still intact. $\endgroup$ – P4wlos222 Nov 30 '19 at 19:22
1
$\begingroup$

Ok. The solution was to recalculate normals by using Shift + N . The problem was, that faces were facing wrong way. Blender renders fronts of faces in higher quality than backs, and mine were facing front and back in checkerboard, so that explains checkerboard thing. Recalculating normals rotated them the right way. I think that they rotated when I was messing with UV unwrapping.

| improve this answer | |
$\endgroup$
0
$\begingroup$

The normals of the faces were facing inwards.

Solution: "Recalculate Outside" by selecting all faces of the object in edit mode with A and then pressing Shift+N.

Some details:
Many operations while modelling can accidentally cause messed up normals, especially if one uses shortcuts and presses the wrong keys(combinations). As face orientation is not very obvious if not explicitly displayed, it can be missed til later times when the shading suddenly does not work as expected. With the cause and effect delayed by some time it usually does not come to mind where the problem originated. That's why it's good practice to check the "Face Orientation" in between from time to time, preventing confusion in the long run.

enter image description here
Further images are with the option activated

Meshes consisting of vertices, edges and faces have an inside and outside, which normally is the way it is seen from, outside. Thus those faces facing outside are the ones representing the surface of the object and are used to show the materials and such. The other side of the faces would be the inside of the object, where normally you'd not look at them from. If you'd build an inside of sorts, you would build a thickness, resulting of a layer of faces that generate a room between them, the outer layer facing outside, the inner layer facing inside. Again, you would only see the outside faces of the object. Here a demonstration (cut off to show the red inwards and blue outwards facing normals.
enter image description here

That's because inside/backsides of faces do not get calculated the same way for visualization as in render or any form of shading. Also affected are subdivision modifiers, and they generate a big part of the effects leading to confusion. Here a simple example with one face wrong oriented on a subdivided cube:
enter image description here
The modifier seems to completely ignore the wrong oriented face

That's why when two faces beside each other have different normal orientation, the shading will generate a break between them depending on the materials used that can become even more obvious. Glass is one of those extremes. Using the "Face Orientation" option is the easiest way to check and find problems as it displays the orientation of faces blue for outside and red for inside as you look at the outside of the object, all should be blue.

While most the time Blender manages to correct normals if you select all elements (vertices/edges/faces) in edit mode with A and press Shift + N, it may be necessary to manually select the faces involved and use the Alt+N Normals menu and select Flip to correct the orientation.

Happy Blending

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.