Here is the link to my Blend file.

Picture: enter image description here

It's nothing special but I cant figure out why I get problems rigging this mesh. It would be important and a great Help! Thanks for reading and I know there are a lot of guides answering this question but I tried all and it doesn't seem to work.

  • $\begingroup$ Please, can you describe more precisely what is the problem? I can't help you because I don't know what is the issue here... Is it about vertex groups and weight painting? Or about the armature and hierarchy of the bones? Please clarify your question. $\endgroup$ – Polosson Sep 17 '14 at 21:55
  • 1
    $\begingroup$ @Polosson I think the OP tried to parent their mesh to an armature with automatic weights, but it gave an error. $\endgroup$ – gandalf3 Sep 17 '14 at 22:15
  • $\begingroup$ Hey guys! I'd post an answer but I can't. Took me a while to figure out why i was experiencing this. I am targeting UE4, so my scale is super small. This was the issue. I scaled up 100x and the weighting was able to succeed when re-parenting... $\endgroup$ – Brad Goss Apr 22 at 4:55

I know 2 situations where this problem raises:

  1. When the Object consists of 2 or more separated (not connected) meshes which intersect. This could be solved by fixing the mesh topology, like connecting the intersecting meshes into one single mesh and by fixing your model to avoid the intersecting areas.
  2. When the object has duplicate vertices. This can be solved by removing doubles in Edit Mode ( keyboard shortcut "W" -> Remove Doubles)

I do not know the exact reason why the algorithm fails in these cases and if there are other cases as well where it fails. However it must be related to ambiguities while calculating the weight ratios for the involved vertices.

I took a quick look into the blend file that was provided by the OP. I found the head of the character has many duplicate vertices (about 320). Removing doubles solved the issue in this particular case.

| improve this answer | |
  • $\begingroup$ As well as duplicate vertices, non-manifold geometry can cause this too. $\endgroup$ – Sazerac Mar 12 '19 at 0:48
  • $\begingroup$ "Remove doubles" fixed the problem for me $\endgroup$ – Jayesh Jun 28 '19 at 14:32
  • 5
    $\begingroup$ Blender 2.81 => Edit Mode / Select / Mesh Menu / Clean Up / Merge by Distance $\endgroup$ – Alex Nolasco Jan 20 at 0:17
  • 2
    $\begingroup$ Cheers OP and @AlexNolasco that saved me. Blender 2.8+ users, "Remove doubles" is renamed to "MERGE BY DISTANCE" as mentioned above! $\endgroup$ – Joehot200 Apr 14 at 13:28

I removed two duplicate verts from my model and it helped.

When that alone did not fix it, I also removed the Subdiv Modifier and was able to generate automatic weights. I had been able to assign envelope weights beforehand.

| improve this answer | |
  • $\begingroup$ you have enough reputation points to edit posts and improve them $\endgroup$ – user2816 Jun 8 '16 at 19:34

I found that my vertices were too close together once I used the relax option twice from the W menu, right click bottom option in 2.82a, my rig and model paired perfectly, only a little tweak on the head and jaw bone.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.