0
$\begingroup$

I'm experiencing an issue when applying a boolean modifier to my mesh. I've tried subdividing, I've tried checking the normals of everything and they all are facing outward (verified by the blue shading when in edit mode), and i tried removing doubles, but I'm not sure what to do. Does anyone have an idea as to what I might have done wrong? You can see the issue with the attached screenshot, or you can download the file via a blend-exchange link provided. This file doesn't have the applied modifiers however so you can view topology and wire frames of the model. Thank you in advance!

$\endgroup$
  • $\begingroup$ it looks like bad topology like stretched triangles, but it's hard to say without the wireframe, or maybe share your file before applying the boolean: blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Nov 30 '19 at 18:45
  • $\begingroup$ Hi moonboots! I think you're correct, but I'm unsure as to where that might be. I've added my file to blend-exchange as you suggested and have provided the link in the post after editing it. I made sure this was a version prior to any application of modifiers. Please let me know if you find the issue! $\endgroup$ – surfmaster96 Dec 1 '19 at 6:07
  • $\begingroup$ Your object doesn't have any Boolean modifier, I meant keep the modifier but don't apply it, could you please share the file with the modifier? $\endgroup$ – moonboots Dec 1 '19 at 8:50
  • $\begingroup$ Hi moonboots, my apologies! I reuploaded and ensured that the boolean modifier was added but not applied. The side button was the only object I used the modifier with as I wanted to resolve the issue before messing with the modifier with any other objects. The newly provided link in the post should provide this file for you. $\endgroup$ – surfmaster96 Dec 1 '19 at 22:30
  • $\begingroup$ Your boolean doesn't work fine, I'm not sure you can improve it, by the way boolean will be improved in a next Blender version. And anyway it leaves ngons, ngons may create artefacts like the one you see. You could fix it manually, but in my opinion you should rework with a simpler topology and less modifiers. $\endgroup$ – moonboots Dec 2 '19 at 8:43
0
$\begingroup$

Its not good to stack a lot of un-applied modifiers when you are using booleans - they are temperamental and it is better to apply the mods at every step. I have applied all of your mods in the order they appear up to the boolean operation and the phone case has 1104 zero faces and 48 zero edges created in the steps you have taken. You can remove these by selecting all in edit then using mesh/cleanup/degenerate dissolve and then your booleans will work better. Any work involving booleans benefits massively from enabling the in-built 3D printing add on in preferences.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.