I'm trying to create a gravestone with chiseled text on it.

I have a cube (the stone) a text for which I added some depth and bevel, and then converted to a mesh.

I positioned the text so that it's partly "inside" the cube and tried adding a boolean difference modifier on the cube (cube - text), so that the text would be chiseled in the stone.

This gets Blender crazy. Initially nothing worked. I used a decimate modifier on the text to reduce its complexity, and now A few letters are chiseled, the rest are not.

This is how things look when Both the cube (headstone) and the text (now a mesh) are visible (there's another grave base object, but we can ignore it):

Both gravestone and text shown

The gravestone has the boolean difference modifier, and if I hide the text, this is what I see:

Gravestone with some chiseling

What can I do to make this work? I don't actually need to render this scene, I want to convert it to an STL file and 3D print it.

More info: As stated in the comments, this is due to the text being non-manifold. Actually, it has 2000+ non-manifold edges!

If I try to remove doubles, it just deletes the entire text. No matter what the double threshold is (tried 1mm, 0.1mm, etc. - I'm working with metric units).

Any suggestions on this?

The file with the issue can be found at: this location

Another file can be found at: this location.
This time, I've used the remesh modifier, but it only worked for one text object (converted to a mesh and remeshed), not the other two. The difference between the one that works, and the others that don't is that for the first one I used Octree depth = 7, and for the other two I used Octree depth = 8 (as 7 wasn't smooth enough).
To test this, just replace the object used in the boolean modifier of the cute from 'RIP' (which works) to either 'iGoogle' or 'years', which don't work.

  • 7
    $\begingroup$ Most likely it's because the text is non-manifold. Try selecting the text in edit mode and pressing W > Remove doubles. $\endgroup$
    – gandalf3
    Sep 17, 2014 at 20:53
  • 3
    $\begingroup$ Also, make sure all you normals are correct(Edit mode > Select Everything(A) > Ctrl - N). $\endgroup$ Sep 17, 2014 at 21:12
  • 1
    $\begingroup$ Boolean operations will sometimes fail if one of the objects is super low poly. You could try sub-dividing the head-stone once or twice. $\endgroup$ Sep 18, 2014 at 16:08
  • $\begingroup$ Hm.. Is it possible you could you upload your .blend? $\endgroup$
    – gandalf3
    Sep 19, 2014 at 18:23
  • 1
    $\begingroup$ for this specific requirement I would be using a displacement modifier with a bitmap. It works like a bump map but creates/modifies real geometry. $\endgroup$
    – rob
    Sep 23, 2014 at 13:26

2 Answers 2


Try adding a remesh modifier to the text:

enter image description here

Then the boolean modifier will work as expected:

enter image description here

  • $\begingroup$ This definitely works. The end result still fails the manifold test in the 3D printing tools, but the result STL can be sliced for 3D printing (tried slic3r). $\endgroup$
    – Barak
    Oct 12, 2014 at 18:09
  • $\begingroup$ The solution seems to only work for the word 'RIP' ;-) Tried another example with 3 text objects, but only one worked. Uploaded the file. Thanks for the great help so far. $\endgroup$
    – Barak
    Oct 12, 2014 at 19:45
  • $\begingroup$ The normals are off on the other text objects, but Ctrl+N won't work because for some reason they are still non-manifold.. $\endgroup$
    – gandalf3
    Oct 13, 2014 at 3:29

Correct the normals of your text.
Select the text, enter the Edit Mode, Select Everything A, and press CtrlN, then go back to object mode.

  • 2
    $\begingroup$ You know how stack exchange works, but yet you used an answer to try to @reply to two other users. You must know the @ ping system does not work in answers, and answer should not be used as comments. $\endgroup$
    – David
    Dec 11, 2016 at 3:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.