4
$\begingroup$

Before submitted that question I have made quite extetensive research and could not find the answer. I am quite new to Blender so I believe there is a chance the answer to my question might be simple but due to my lack of experience with Blender I did not recognize that.

The problem seem to be simple yet it is pretty complicated for me especially that I am trying to do beveling in non destructive way.

I have a simple plank with excision on one side. The excision was made in destructive way but the beveling is applied through modifier with weight kimit method (I am using speedflow and fluent).

enter image description here

Then what I am trying to do is to apply small bevel (about 1 mm) to all edges of the plank except four of them which are adjacent to one face.

enter image description here

I can - using bevel modifier - apply that additional beveling to all edges using angle as limit method but I do not know what to do to keep the selected edges sharp.

enter image description here

Not using any limit method (None) creates strange artifacts

enter image description here

While it is impossible to use vertex group as the edges I want to keep sharp are between verticies which are also part of the other edges that I want beveled.

----- EDIT -----

I have tried the method suggested by Merlin - applying bevel weight to individual edges - but it only works with simple geometry.

enter image description here

With more complex geometry it creates artifacts again.

enter image description here

$\endgroup$
  • $\begingroup$ Have you tried with multiple vertex groups, with a separate bevel modifier for each group? $\endgroup$ – Moog Nov 30 '19 at 11:35
2
$\begingroup$

You can set bevel weights on individual edges.

To enable this feature in the modifier, select Weight

Now go into edit mode and make sure you are in edge selection

Now select the edges you want to bevel (shift click for multi-select).

Now go to the Edge menu and select Edge Bevel Weight

Move the mouse to modify the value.

Once done you can use the panel as shown:

You can fine tune this after by hitting F9 to modify last operator.

Update

So while this works for most geometries, it seems that something odd has happened in your file. I suspect that one of your addons has already been weighting your edges and combined with what we are trying to do here, makes for an unhappy mesh.

So I removed all you modifiers and created a vertex group with 4 vertices for the excision ( cut-out). Then, I recreated your bevel modifier with 40mm. The trick to getting this working correctly is adding an edge-loop in the center as shown.

Now you should have your rough cutout shape. Here's the settings I used for this first modifier.

N.B. you must use Width Method: Width here:

So now it's time to setup the second bevel modifier weights as described above.

Make sure to pay attention to which edges have weight here:

And finally the settings I have used for this second bevel modifier are:

And the final geometry:

|improve this answer|||||
$\endgroup$
2
$\begingroup$

The solution presented above works well. I would add however a few more observations that only enhance the solution of Merlin, which by the way I am very grateful for.

First of all the selection of initial four verticies. I know it is obvious thing for those who know Blender very well but for some other greenhorns like me it can be a deal breaker. Once the loop cut is added (as on Merlin's screen) it is paramount that those 4 verticies are added with Shift pressed not Ctrl. With Ctrl pressed you add also middle two verticies (of the added loop cut) and that will not work at all.

This is what you will recieve when adding verticies with Ctrl (as I was doing for quite a long time - shame on me). enter image description here

And this is what you get when you add vertices with Shift pressed.

enter image description here

Merlin has written that the for the first bevel modifier you need to choose "Width" as Width metod. It is not exactly true. The point is the you can also choose "Offset" but the sum of the first Bevel modifier value and the second one cannot be higher than the depth of cut-out. And that actualy makes sense. In my case the last 1 mm of the cut-out is used to bevel the outer edge so the bevel that creates the curve within the cut-out cannot be bigger than 40 mm - 1 mm..

enter image description here

It is also very important that for the seconf bevel the Loop Slide option is checked. Otherwise you will experience some artifacts. As shown below.

enter image description here

So I believe that concludes the thread. Once again very big thanks to Merlin for his will to deal with subject and patience for us noobs.

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Yeah I wasn't sure about the offset thing, perhaps "must" was too strong, it just seemed to be the simplest way to get reliable behavior. I guess you were going for exact measurements here. $\endgroup$ – Moog Nov 30 '19 at 18:33
  • 1
    $\begingroup$ Anyway. Thank's for help. My understanding of Blender is much better now than it was a few hour back. $\endgroup$ – Jan Pips Nov 30 '19 at 18:35
  • $\begingroup$ Also just a handy hint about selecting or anything that uses a modifier key, if you look in the bottom bar with Ctrl, Shift, Alt or any combination held down, it shows you some mouse icons which tell you what they do. In your case it was pick shortest path, $\endgroup$ – Moog Nov 30 '19 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.