5
$\begingroup$

Trying to follow an Andrew Price tutorial for procedural displacement but when the tutorial goes to procedural displacement I get zero effect, except in surface shadows, when the edges of the object should be displaced, and in the tut look like a sea urchin. Have tried this a few times but can't see where I am going wrong, it seems to be a really simple thing but all the other resources I can find are discussing slightly different procedures. To be clear - I am trying to apply a procedural noise texture (not UV mapped) to a simple object. It doesn't make any difference if I subsurf it or not. He says to change the material option from Bump to Displacement in the material settings but in 2.81 it is default anyway. I want to make a big ocean scene with physically large waves.

I have tried some solutions from the youtube comments such as turning on a bit of subsurf - although that makes no difference and I don't know what it has to do with displacement... Tried turning on experiemental features, double checking I am using cycles... Checked all views, including rendering, this thing is still as smoooth as eggs smooth as eggs

$\endgroup$
9
+100
$\begingroup$

The property you need to change is rather hidden in the UI unfortunately. Blender allows you to change the behavior of Displacement vector inputs per material. So as a result, there is a dropdown box in the Materials tab in the Properties Editor, under Settings -> Surface -> Displacement:

Displacement Property

By default that will be set to Bump Only. Change it either to Displacement - which will displace the geometry - or Displacement and Bump, which will first displace the geometry and then apply the same texture as a bump map on top of that. Result looks like this in your file:

Result

Second, in case you want to go really high with the level of detail, you'll need to enable the Experiental feature set to get Adaptive tessellation. Adaptive tessellation (sometimes called Microdisplacement) will give you more geometric details in areas when needed. Here's where to enable it first:

Adaptive

And here is the checkbox that needs to be enabled in each SubSurf modifier where you want adaptive displacement to kick in:

adaptive in modifier

If you now render, you can see that the detail is a lot smoother, simply because now there are far more triangles in the mesh than before to capture the displacement detail:

result

$\endgroup$
  • $\begingroup$ Perfect - thanks! $\endgroup$ – John McCarthy Dec 2 '19 at 12:15
  • 1
    $\begingroup$ Make sure to change the value of the adaptive subdivisionslide from time to time, it sometimes doesn't update like it should @JohnMcCarthy $\endgroup$ – WhatAMesh Dec 2 '19 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.