In order to generate a bone rig I have created the metarig and adjusted it to my model/character. As I am trying to create something simple (to use it in Unity), I removed the face and ears.

Character with the metarig

Then I re-calculated the noremal ("Shift + N" and then "Y").

Once I generated the rig (Object Data Properties > Rigify Buttons > Generate Rig) I got the following error:

Generation has thrown an exception: 'bpy_prop_collection[key]: key "ORG-nose" not found'

And in the Layers it appears a new one named "rig" and it highlights the following:

New Layer - Rig

What am I missing here?


Found the problem.

The face bones were not all removed as I saw one inside the big bone when I moved it.

Small bone

Removing that small isolated bone solved the problem.

Problem solved


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.