1
$\begingroup$

I'm trying to make an eye and while adding the outer later that makes it shine it's turning it dark instead. It's supposed to look like this: enter image description here But ends up looking like this: enter image description here

Does anyone know what's up? Here's my blend file.

$\endgroup$
1
$\begingroup$

It looks like it's mostly the lighting. In the example it looks like they're using an environment like an HDR map or something, but in your scene you just have 2 lights. I just added this:

enter image description here

and I got this:

enter image description here

...which is much closer to the example. Of course the other main difference is the tutorial is using Blender 2.8 and yours looks like 2.7x, which will have differences.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks. It works now, one more question, do you know how to get the scene to be less grainy in rendered mode? $\endgroup$ – Tamari Campbell Nov 29 '19 at 8:28
  • $\begingroup$ you need first to increase the Samples value in the Render panel > Sampling $\endgroup$ – moonboots Nov 29 '19 at 8:36
  • $\begingroup$ Alright then, thanks. $\endgroup$ – Tamari Campbell Nov 29 '19 at 19:42
  • $\begingroup$ You don't necessarily need to increase the samples. I'd try setting the "Clamp Indirect" setting to 0.9 instead of 0. That should clear up the bright speckles. Also if you found my answer useful you should mark it as the correct answer. Thanks! $\endgroup$ – Dale Cieslak Nov 29 '19 at 21:42
  • $\begingroup$ Oh, I didn't notice you could set an answer as correct. Just did, thanks again, I'll have to try the clamp indirect. $\endgroup$ – Tamari Campbell Nov 30 '19 at 4:11
1
$\begingroup$

He's in Eevee, maybe that setup works fine in Eevee, but in Cycles I think you need at least to mix your Principled BSDF (with 1.00 Transmission) with a Transparent BSDF node. There is a lot of solutions (like use Fresnel in the Mix factor, use Glossy, etc) but it will always be a mix with Transparent BSDF in my opinion.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks for the tips, I'll have to do further tweaking to see if it works, it made the eye clearer though I couldn't see the shell at all. $\endgroup$ – Tamari Campbell Nov 29 '19 at 9:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.