1
$\begingroup$

It's the latest build v2.81.16

When I press A once it should select all but now i have to smash it at least ten times before it selects all but usually it just deselects everything. SO, how do I select all now? Preferences says that its binded to A but that's not the case apparently.

$\endgroup$
  • $\begingroup$ Not seeing the same issue, same version ... do you anything else bound to A? Is there an issue with your keyboard? Can't think of anything else. $\endgroup$ – Moog Nov 28 '19 at 19:41
  • $\begingroup$ Nope, I haven't touched them at all. And I'm pretty sure my keyboard is okay, maybe it magically fixes itself or I just learn how to use these things. Either way, would have been nice to have the option between these new pie menus and the old ones. $\endgroup$ – user84654 Nov 28 '19 at 19:57
  • 1
    $\begingroup$ One thing that it different it would seem is that deselect all is double-tap A. Seems you are having the opposite problem to me. If you're on windows make sure that you don't have sticky keys enabled. $\endgroup$ – Moog Nov 28 '19 at 20:07
2
$\begingroup$

This really sounds like a keyboard issue where you're getting double "A" keypresses registering. In my experience, it's not unusual to have a bad connection on a keyboard that you don't notice much during regular typing but that acts up when you use a key shortcut, just because of differences in the positioning of fingers and force of keystrokes when touch-typing versus using shortcuts. Also remember, if you do any gaming with this keyboard, the WASD cluster tends to suffer some of the worst abuses.

I'd suggest disabling the dbl-A ("double click A") mapping in the Keymap preferences, to see if that resolves the problem. In Preferences -> Keymap, search for "Key-Binding" of "A" and unclick the checkboxes for the dbl-A bindings -- note that there's a binding for each mode, so maybe disable "Object Mode" and "Mesh" to start. If that fixes the problem, then Blender is registering double-taps on the "A" key, whether your keyboard is to blame or not. You may also want to try checking in an editor whether hitting "A" at different angles or with less than usual force occasionally registers multiple keystrokes.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.