2
$\begingroup$

I have this problem with blender. I have created a mesh consisting of around 400 vertices. In Cycles Render I added a Glass Shader and connected the "Generated" Output of the "Texture Coordinate" Node to the "Color" Input of the Glass Shader, because of this its pretty colorful. So the problem is, that if I render it there are those black rendered faces, as seen image I have also put the Blender File on Google Drive, so you can look at it: click here.

Does anyone know how I can fix those faces?

$\endgroup$
1
$\begingroup$

This has a rather simple reason.
Your edges are too sharp, and Blender doesn't like it.

Solution
1) Apply a small bevel to your edges
2) Set shading to smooth
3) Boom. You're done.

Bevel outer edges.
This will take care of those sharp edges, and also make Blender happy.
4 segments are enough, set the width as desired.

enter image description here

Set smooth shading.
This will smooth out the normals, so the transition is more gradual.
enter image description here

Looks good!

$\endgroup$
  • $\begingroup$ Thanks for the help! That worked really well, although I am using Blender 2.78 so I had problems to find the bevel and shade smooth option. For anyone with the same problem also using Blender 2.78: Bevel: If you use the Bevel modifier you can edit the same Values | Shade smooth: Object mode > Menu on the right side > Tools > Shading: Smooth $\endgroup$ – Janniboy Nov 30 '19 at 14:25
  • $\begingroup$ Happy to help :). Bevel modifier is actually a better solution in this case, because it keeps your changes editable until you apply it. Btw, smooth/flat shading is also hidden under right (or left?) click. $\endgroup$ – ᴊᴀᴄʜʏᴍ ᴍɪᴄʜᴀʟ Nov 30 '19 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.