1
$\begingroup$

I don't understand the unit setup. I need to print the model but its just still incorrect in dimensions.

I have set up length to millimeters unit scale 1.

Exported STL file in meshmixer shows that cube that has 100mm in blender is 0.1mm, how does that work?

Also, blender does not scale the model when changing the measurements.

e.g. A model that has 10cm when I change to millimeters it just show that it has 100mm. Do I have to manualy rescale?

Can someone enlighten me to how to set scale, units and grid size to actually work in the units and export in them as I want?

$\endgroup$
  • $\begingroup$ There's a great addon by Campbell Barton called 3D Print Tools that has a Scale To Bounds button that does what you are looking for. It is supplied with blender, you just have to enable it. $\endgroup$ – Moog Nov 30 '19 at 12:08
1
$\begingroup$

The STL format does not support units. It just records arbitrary X,Y,Z coordinates of the vertices for each face. Blender cannot know the units you intend.

blender scenes have their own co-ordinate system. Unit system and Unit Scale just offer consistent display of properties through the user interface. The objects themselves remain unchanged, because equally these do not have real dimensions either, much like the STL file they just have an arbitrary X,Y,Z.

To fix the problem with your STL you must enable the Scene Unit checkbox in the STL exporter options as shown. It is also worth using the Selection Only to avoid exporting unwanted geometry.

STL exporter options.

Please note that the STL importer also has similar settings.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Yep I already check to use scene units and exporting just the model I want. The problem is more in the corelation of unit scale and unit setup. The unit set up itsel does nothing except the number in which is the lenght shown... like 10cm just will be 100mm or 0.1m it does not have effect on actual size or proportions. Its all about the unit scale. When you import model that is 10 meters big and you dont want to actually scale it the solution is not to set up the meters to centimeters you have to set up the unit scale to 0.1 which is confusing rather then just to click meters to centimeters. $\endgroup$ – Fowl Nov 27 '19 at 6:49
  • $\begingroup$ I agree it is confusing and something that needs looking at. So this is where the STL format falls down, and blender follows. I had tested this in and out of blender and it works well, inicluding setting up odd scalings, however I should have checked with an external app. I remember going through the same thing when I had a 3D printer, I'll update the answer when I have time. $\endgroup$ – Moog Nov 27 '19 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.