0
$\begingroup$

Default behavior for LMB+drag in any timeline panel (timeline, dope sheet, action editor etc.) in Blender 2.8 is to create a selection box instead of scrubbing through animation. I have the B key to enter box select if I want to select things - I don't need this new method of selecting things.

I've managed to disable the selection box, but the scrub still doesn't work - now if I hold LMB and drag on the timeline it just does nothing. And I don't want to have to click on the frame number panel (which does what I want it to when I click and drag on that - see picture for clearer explanation).

enter image description here

$\endgroup$
1

1 Answer 1

1
$\begingroup$

Resolved: Preferences > Keymap > Animation > Change Frame

Default value: shift right mouse

Change to: Left mouse

Note: No need to disable the "box selection" behavior. This overrides that. The above change is all you need to do.

enter image description here

$\endgroup$
1
  • $\begingroup$ 3.30 does not have a Change Frame entry under the Animation section; you need to add it. You can get the code to use from the other Change Frame entries; it is "anim.change_frame". $\endgroup$
    – blr
    Commented Oct 18, 2022 at 12:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .