0
$\begingroup$

I have created a FlipFluids simulation in Blender 2.81 ( 2019-11-25 21:45) and added an Ocean modifier in displacement mode to the fluid_surface. Then I have baked the complete sim from within FlipFluids.

When I move from keyframe to keyframe in the default timeline everything is moving as desired in the default 3D window:

Ocean modifier waves, FlipFluids waves & wake, flags, radars...

When I render the complete animation everything EXCEPT the ocean modifier waves are moving. The ocean modifier waves remain static but the FLIPFLUIDS waves move on that surface.

I like to add that ALL modifiers and elements ARE enabled for renderings. D-NOISE: AI Denoiser is on (switching denoiser off did not help). I run a Win 10 Pro, HP Z800 with dual Xeons, 72 GB of vRAM and a GTX 1060

If I render & save the frames manually individually by hand the ocean surface moves! But thats not something I really like to have to do on several hundred frames

As its working when rendering&saving each frame manually as image (Png) and its not giving the same result when saving out the same images (Png) when I hit render animation, I do suppose this might be a bug in 2.81.

Does anyone have an idea how to fix this, preferably without rebaking?

$\endgroup$
0
$\begingroup$

Turned out to be a bug in Blender 2.81. The team of Blender will be fixing it:

https://developer.blender.org/T71908

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.