2
$\begingroup$

I have a scene full of objects that won't export properly (I need either FBX or Obj, it's for Unity but that's irrelevant). After a lot of work I've been able to narrow down the problem to the fact that those objects are not being properly counted.. (see picture, objects counts 0..) The objects that are being counted export fine. :(

zero count

Any idea what is wrong with those objects?...

I have a work-around: joining a problematic object to a working object, and then separating them again, but there are dozens of objects in that scene, it would take me days to fix all this like that.

Any help would be very welcome. :(

$\endgroup$
  • $\begingroup$ Aloys, Welcome to the site. Is this a linked item, by any chance? If not, you're probably going to have to provide a ~.blend file with this one... $\endgroup$ – brasshat Sep 16 '14 at 16:56
  • $\begingroup$ Thank you for your answer Brasshat. None of these items are linked or instance. I have tried making them single users anyway, no change. In case that's any help here is a scene with problematic objects. $\endgroup$ – Aloys Sep 16 '14 at 17:42
  • $\begingroup$ Also I have noticed that if I add a new object (any kind: mesh/camera/empty..), it is not taken into account either. That totally baffles me. =( $\endgroup$ – Aloys Sep 16 '14 at 17:44
5
$\begingroup$

Only objects which are in visible Scene layers are counted in the info header.

Note the difference between Scene layers and View layers:

  • View layers are set in 3D view > Header, and are independent between different 3D view editors. Only objects in the the current 3D view's view layers are shown in that 3D view.

  • Scene layers are set in Properties > Renderlayers > Layer > Scene, and control the visibility of objects for the enter scene. This visibility is used for scene-wide operations such as renders and exports.

By default these two layer sets are locked together so that they are always set to the same layers, however this option is disabled in your file (1).

Either re-enable this option, or set the scene layers to match your view layers in the header of the 3D view (2).

enter image description here

$\endgroup$
  • $\begingroup$ Bingo! That was the problem. :) Thank you for that info, I couldn't find it anywhere else... I don't understand why that freaks out the export, but it does.. Thank you again for the tip! $\endgroup$ – Aloys Sep 16 '14 at 19:18
  • $\begingroup$ @Aloys See my edit :) $\endgroup$ – gandalf3 Sep 16 '14 at 19:21
0
$\begingroup$

I don't really know what's wrong, but appending all the objects to a new file works; Objects are counted again.

Create a new File, By going to the Header>File>New or pressing Ctrl + N. Then go to Header>File>Append or press Shift + F1, locate your *.blend file, click it, then go to Object and select the objects you want to import to the new file.

$\endgroup$
  • $\begingroup$ That works; thank you so much! I'm still puzzles by what went wrong, but at least I can keep working. Thank you! $\endgroup$ – Aloys Sep 16 '14 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.