So I got a problem. I recently started with Blender and I created this low poly character. I already rigged her and moving the bones works good. Now I wanted to do some weight painting to prevent certain bones to move certain parts of the mesh. The problem is that I cant use weight paint properly.

So here is my mesh with weight paint. You can see that when I select the bone the automatic weight paint works just fine. enter image description here

enter image description here

On the second image though you can see the only part i can actually paint. Its only this specific part of the head, thats it. Someone ever had this problem and knows a fix for this?

Thanks for your attention!

  • $\begingroup$ Have you perhaps locked some weights? $\endgroup$ – Leander Nov 24 '19 at 19:49
  • $\begingroup$ I didn't lock anything as far as I know but there is a great chance that I did that by accident. I definitely look into that tomorrow/later. I update it once I tried. Thanks for the reply :) $\endgroup$ – Luke Krieg Nov 24 '19 at 21:45
  • $\begingroup$ Just in case: blender.stackexchange.com/q/72358/30849 $\endgroup$ – Leander Nov 24 '19 at 21:45
  • $\begingroup$ @Leander I followed the short tutorial you send me but they are all unlocked. When I lock them then of course no paint can be applied. But when unlocking all only the same part of the head can be painted. I tried different Models and I got the same problem on every model I create. For example I created a Sphere in a new file and directly head to Weight paint. There I can also just paint one paticular area. I think I got a problem with the settings maybe? Or what else do I need before weight painting? $\endgroup$ – Luke Krieg Nov 25 '19 at 14:57
  • $\begingroup$ Ok I found out some new weird stuff. So I changed the screen lay-out to "compositing" ( it works in others aswell), and there it actually worked on the right side of the model ( only the right side). Maybe someone can use this information better than I can... $\endgroup$ – Luke Krieg Nov 25 '19 at 17:49

The problem is in your Mesh. Go to edit mode, select all Polygones an then click ALT+N and chose recaculate outside.

That is because the Polygon have 2 sides. Front and Backside. You cant paint on the backside of the Polygon


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.