0
$\begingroup$

I'm trying to make an animation of a fade in, but when using transparent shader, glass with 1 IOR, Alpha, anything casts shadow. I just wanted to make the object disapear from the scene, and smothly apear in order.

Here is the evidence.

shadow or ambient occlusion, I dunno

enter image description here

$\endgroup$
  • $\begingroup$ transparent causes this issue, and holdout don't work with mixer, it makes the object invisible for good regardless of the factor.... But thanks, i didnt't know the holdout. $\endgroup$ – Akaize Nov 23 '19 at 15:21
  • $\begingroup$ You can see in the image that the sole is casting shadow on the ground, I'll try to make 2 keys, 1 of render e another with the factor, to see if combined they work. $\endgroup$ – Akaize Nov 23 '19 at 15:29
  • $\begingroup$ Is that transparent part intersect with the shoes itself? Maybe an wireframe screen shot can help to resolve the problem $\endgroup$ – HikariTW Nov 23 '19 at 15:37
  • $\begingroup$ That is the sole from inside the shoe, and the shader I was trying to apply changing the factor. $\endgroup$ – Akaize Nov 23 '19 at 15:45
  • $\begingroup$ There will be two or more surface been saw from camera angle. This is not allow to use any surface transparent without some darken overlay. And you mesh is complicate also. I would probably render 2 frame and interpolate them directly rather than using a transparent material. $\endgroup$ – HikariTW Nov 23 '19 at 15:56
2
$\begingroup$

Two possibility in my mind:

Object → Visibility → Ray visibility → Shadow in the object properties panel. (set to unchecked)

enter image description here

Material → Setting → surface → Transparent Shadow in the object properties panel. (set to checked)

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks, but withou any shadow, the final fade-in will not work. And the transparent shadow is already checked. $\endgroup$ – Akaize Nov 23 '19 at 15:32
2
$\begingroup$

Ok, know I get it.

What I was seeing was the texture AO and not a shadow, sorry guys. What I did was:

1 - removed the AO + color ramp from my textures.

2 - changed the world configuration adding AO with the same AO configuration from my textures.

3 - 1 frame before the fade effect, I changed the object render from disable to enable, then it's lighter to process the scene.

Now it's working. Thank you guys! Just a test, I need to polish more, change some times and orders, and only then, render in Cycles.

https://www.youtube.com/watch?v=u1nfQLAX064

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ +1 for figuring it out ... it's not always such a quick process $\endgroup$ – Moog Nov 23 '19 at 20:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.