1
$\begingroup$

Everything is done in Cycles.

I created a very simple blue volume and gave it to a cube. I also added a principled shader to make the outside look like shiny glass.

material settings

The cube on the left has only the volume. The cube on the right has both the volume and principled shader.

first render

As you can see, the glass causes the volume to lose all color. As it turns out, it is somewhat related to shadow casting, because if I turn off shadow casting by my sun lamp, the color returns to the right cube.

second render

Why is this happening, and how do I keep the color of the volume without disabling the shadow casting on my light?

$\endgroup$
  • $\begingroup$ I don't think there way, as there is a reason why most shaders don't have both "Surface" and "Volume". $\endgroup$ – Yohello 1 Nov 22 '19 at 18:22
  • $\begingroup$ I can't reproduce this. Works fine for me with and without shadow casting enabled. $\endgroup$ – Robert Gützkow Nov 22 '19 at 18:39
  • $\begingroup$ @Yohello1 I also tried to create a slighly bigger box which would surround the original one. Original one had only volume shader while the bigger one had only principled glass shader. I had similar results. $\endgroup$ – aphatetic_artist Nov 22 '19 at 18:39
  • $\begingroup$ @RobertGützkow I updated the post with a link to the .blend file. Could you try my file? $\endgroup$ – aphatetic_artist Nov 22 '19 at 19:06
  • $\begingroup$ Please upload your blend file to blend-exchange.giantcowfilms.com and add the link to your question. This will preserve the blend file for the future. $\endgroup$ – Robert Gützkow Nov 22 '19 at 19:09
1
$\begingroup$

The Volume max bounces were set to zero in your project. Once you increase them it should give you the intended look.

Light path panel

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.