1
$\begingroup$

The weirdest thing seems to be happening, I am trying to add 3 videos to blender VSE, for this sake we'll call them 1.mp4 2.mp4 and 3.mp4.

Each of these videos is exactly 14 seconds long and within 150 kB of each other in size. They are all the same frame rate.

No matter what I do 1.mp4 is only about half of the video when I add it to the video-sequence editor, the rest work fine.

enter image description here

I've tried messing with the start and end frames and the frame rate but changing these doesn't appear to affect anything with 1.mp4's length.

I have also simply tried extending 1.mp4's length in blender but obviously there's no video on the second half.

I have played all 3 videos in VLC and they play just fine so I know it's not a corrupted file.

$\endgroup$
  • $\begingroup$ Apologies, when I drag and drop from the file select window into the sequencer window only about 7.5 sec of 1.mp4 appears on the sequencing window. 2.mp4 and 3.mp4 when added the same way to the sequencer window have the full 14 seconds. Here's a screen cap of the issue for reference: ibb.co/2F0jK0G $\endgroup$ – Aaron Lind Nov 22 '19 at 22:07
  • $\begingroup$ I've updated your question to make it more appealing (that was a lot to swallow in one paragraph). Just need to wait for it to be peer reviewed. Can't help with the issue I'm adraid, the only thing might be that the channel might have some scaling on it. Sometime worth closing blender, starting a new blend file and see if it does the same. $\endgroup$ – Moog Nov 22 '19 at 22:18
  • $\begingroup$ I appreciate the help, I have attempted restarting blender as I initially assumed it must have been a setting I tweaked but to no success! $\endgroup$ – Aaron Lind Nov 22 '19 at 22:20
  • $\begingroup$ I thought you probably had, just checking in case you got stuck into the rabbit-hole and hadn't pulled yourself out again. Hopefully somebody will have an answer soon. $\endgroup$ – Moog Nov 22 '19 at 22:22
  • $\begingroup$ It looks to me like the lower file in your screenshot got imported at a different framerate. Can you post another shot with the short one selected and the options visible? Also: Do the first and last frames match the ones in VLC? Make sure your project settings have the same framerate as the video files. $\endgroup$ – Frederik Steinmetz Dec 26 '19 at 16:09
0
$\begingroup$

Either there is something different in 1.mp4 or there something wrong in the Blender import of them.

Try to compare the metadata of the clips in MediaInfo if they are similar, if they're not, then that might be the reason.

If they are similar, try to make four copies of one of the good clips, and import them in Blender, if the problem is visible, then do a bug report: Menus > Help > Report a bug.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.