0
$\begingroup$

I've been tasked to install Blender 2.8.1 onto multiple Macs (50+) running Mojave. Our normal method is to simply copy the .app into the applications folder on the devices using Apple Remote Desktop (ARD) and users will run the file from there. However this is not working with the new version. App file copies over fine, however when trying to run it, I get an error that the file may be damaged or incomplete. Permissions set to read for everyone. Hope someone can help? Thanks

$\endgroup$
  • $\begingroup$ Deployment questions are probably off-topic for this site. If you are using blender commercially you should consider paid support. Are you sure there is no corruption of the download, i.e you tested it locally. The file extension would normally be .dmg. Here's the 2.81 download for MacOS $\endgroup$ – Moog Nov 22 '19 at 15:33
  • $\begingroup$ Can you recommend where to get support for this? I work in an educational institution for non profit. $\endgroup$ – PCW8256 C Nov 25 '19 at 9:09
  • $\begingroup$ Can I add that I am sure there's no corruption in the download. I can run Blender on one account, but when I try to run it via another account, it states it's corrupted. $\endgroup$ – PCW8256 C Nov 25 '19 at 16:23
  • $\begingroup$ I think you need an ARD expert, but it sounds like a permissions issue maybe. Read the ADR manual don't skip anything, the lightbulb usually appears after third reading. If all else fails call Apple. $\endgroup$ – Moog Nov 25 '19 at 18:50
  • $\begingroup$ Also, this question really belongs on Server Fault as this is really a deployment problem rather than a blender one, I can't migrate it though I'm afraid. I'll talk to the moderators. $\endgroup$ – Moog Nov 25 '19 at 18:52
1
$\begingroup$

Same issue here, i just rolled back to the previous version.I had just deployed to 400 macs without testing (stupidly). It seems the permissions on the app require you to be an administrator. The person who installs locally has read/ write access, everyone has no access and there are no groups listed in the permissions. I will do some more testing tomorrow changing the permissions. I did give everyone full access but that didn't work.

$\endgroup$
  • $\begingroup$ Have you reported this back to blender? $\endgroup$ – Moog Dec 6 '19 at 18:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.