0
$\begingroup$

I have a decent new build: 3700x + 2x 5700XT, 32gb ram, using 2.81.

I thought smoke rendering for a fairly simple scene would be a breeze (excuse the semi-pun) but for a render of a scene containing a small cube with volume scatter at 1080p, Blender just grinds to a halt and then crashes. The max resolution I've had a successful render at is 640x320!

This is only at 50 samples too.

(I'm using an HDRI for world lighting, plus 2 or 3 small lights dotted about)

Does anyone have any idea how to improve things in this area?

In all other aspects, my new build is blazing fast at Blender.

Thanks in advance,

Jon

$\endgroup$
  • $\begingroup$ I'd suggest share your file: blend-exchange.giantcowfilms.com In best case you'll get a free benchmark... $\endgroup$ – brockmann Nov 22 '19 at 9:50
  • $\begingroup$ Thanks @brockmann - I will upload when I finish work! Speaking of which, I tried running the same smoke settings on my weak old work iMac - rendered fine on just CPU. Something funny going on here. (most likely my fault!). $\endgroup$ – Jonathan Mann Nov 22 '19 at 11:29
0
$\begingroup$

OK, just for reference, I found the problem - it was the Volumes settings!

I had them at the default of Step Size: 0.1 & Max Steps: 1024

It was killing my machine at this setting.

So I changed it to Step Size: 5 & Max Steps: 16 and it's MUCH better now! Only a very small noticeable difference in smoke quality too.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.