2
$\begingroup$

Why is this not transparent? The translucent BSDF works but not the transparent BSDF.

I'm using Cycles as a render engine. I've had this work in the past but for some reason it doesn't want to work anymore.

scvreenshot

$\endgroup$
2
$\begingroup$

It looks like you're viewing this in "Look Dev" (also called "Material Preview") mode:

enter image description here

That uses the realtime Eevee shader, even if you've selected Cycles as your main rendering engine. Click on the little sphere to the right of the selected one for "Rendered" view, and that will probably fix the problem.

You can use transparency in Eevee, too, but it requires an extra setting. You'll need the following steps:

  1. Temporarily switch your rendering engine to Eevee.
  2. With the transparent object selected, click on its material tab and scroll down to "Settings". You should see a "Blend mode" setting. (This will only appear if you've switched your rendering engine to Eevee first.)
  3. Change the "Blend mode" to "Alpha blend" (or "Alpha hash" or "Alpha clip" -- see the manual for details).
  4. Now you can change your rendering engine back to Cycles.

The transparency should now work both in Look Dev ("Eevee") and Rendered ("Cycles").

| improve this answer | |
$\endgroup$
  • $\begingroup$ thank you so much i really appreciate it $\endgroup$ – chocalte car Nov 19 '19 at 22:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.