1
$\begingroup$

When I duplicate an object with Shift+D and then change color it also change the color on the original object. Same if I duplicate with Alt+D. I use Mac if that would matter. Would be happy for any help here since it is very enoying. /Peter

$\endgroup$
2
$\begingroup$

When you duplicate an object, by default the copy keeps the same material as the original. If you want to create a new material for this copy you need to:

  • 2.79: Press U (Make Single User) > Object & Data & Material
  • 2.8: Header menu > Object > Relations > Make Single User > Object & Data & Material.

In the case of a linked duplication (AltD), go in the Properties panel > Material > On the right of the material name click on the dropdown menu and choose Material, this way the meshes of the objects are still linked but not their material.

$\endgroup$
  • $\begingroup$ Also, this default behaviour can be changed in preferences. Edit->Preferences->Editing->Duplicate data. One can select which data get copied and which get duplicated. $\endgroup$ – ᴊᴀᴄʜʏᴍ ᴍɪᴄʜᴀʟ Nov 19 '19 at 20:11
  • 1
    $\begingroup$ Oh ok I didn't know that, thanks $\endgroup$ – moonboots Nov 19 '19 at 20:26
  • $\begingroup$ I press u but nothing happens. But the last part seem to work. $\endgroup$ – Peter Nov 19 '19 at 22:44
  • $\begingroup$ If you're using 2.8, U won't work, you need to go in the header menu $\endgroup$ – moonboots Nov 20 '19 at 8:33
0
$\begingroup$

Go into the materials tab and you will see, next to the title of the material, something that says "Number of users."

If you click that it will make a single user copy so the materials are no longer linked.

$\endgroup$
  • $\begingroup$ Thanks this seems to work. $\endgroup$ – Peter Nov 19 '19 at 22:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.