3
$\begingroup$

I'm trying to enable debug mode in blender 2.8 in order to see vertex indices in edit mode and from the instructions I'm following I'm supposed to execute bpy.app.debug = True but I still cannot see the indices. How do I do this in blender 2.8?

$\endgroup$
4
$\begingroup$

You can enable vertex indices in the Viewport Overlays panel from the 3D viewport. You don't have to set the bpy.app.debug flag explicitly. This option should be always visible. Just make sure to be in the Edit Mode. Object Mode will not show any vertex-related options.

enter image description here

Update

Right, I forgot you have to enable Developer Extras in the Interface settings!

enter image description here

$\endgroup$
  • 2
    $\begingroup$ This developer tab isn't visible on my viewport overlay window... how can I make it appear? $\endgroup$ – Espen Sales Nov 19 at 13:30
  • 1
    $\begingroup$ It works now, thanks! $\endgroup$ – Espen Sales Nov 20 at 6:39
2
$\begingroup$

Overlays are a new feature of 2.8

Setting vertex indices overlay via script

Test script. Sets on for all 3d views in screen.

import bpy

context = bpy.context
for a in context.screen.areas:
    if a.type == 'VIEW_3D':
        overlay = a.spaces.active.overlay
        overlay.show_extra_indices = True

Setting debug is only necessary for versions prior to 2.8

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.