1
$\begingroup$

Introduction

I am new to blender in general but got half a dozen CAD-Systems in my toolbelt. While I am used to each system having it's own quirks Blenders idea is quite different from a classic cad-system used in engineering, leaving me kinda dumbstruck.

Issue

My problem is simple: Whenever I try to transform an object or extrude an edge or vertice, my extrude axis is locked to Z.

Additional Informations

My Object has a modifier to mirror on the z-x plane (normal to y), and the selected vertices/edges can be all found on the z-y plane (normal to x). My scales are 1/1/1, I think it has something to do with me using shift to move the view during extruding. But I cannot find where I can see if an axe is locked or not, any help would be greatly appreciated. Snap is turned off.

Solution attempts:

I tried using mmb to switch the locked axis, I tried e + direction trying to enforce extruding direction, I tried shift + direction to lock and unlock different axis. I am kinda frustrated since these are basic commands anybody uses and I got no clue where they are even shown :(

$\endgroup$
1
$\begingroup$

Are you certain it is locked to the Z axis, and not the normal axis? Both the normal and the Z axis have a blue color, so it is easy to mix them up.
You can see to which axis the extrusion is locked in the status bar while extruding.

enter image description here

You can change the axis the extrusion is locked to by pressing the key corresponding to the respective axis, so either one of X, Y or Z. Pressing one of these keys twice switches between global and local axis, pressing a third time removes all axis constraints during extrusion.

If the selected face normals are not parallel or perpendicular to the global XYZ axii, you will not be able to align to the global XYZ-axis using middle mouse button, as that references the face's normals.

It's also important to know that the default hotkey for extrude(E) will not 'just' extrude as it actually is 'Extrude and Move on Normals'. This means that, by default, it will always try to extrude along the normal axis of the selected face.

If you want to change this behavior, you can change this in the settings. This will change the E hotkey to extrude without aligning to any axis, requiring you to set the axis yourself each time you extrude.

Blender 2.79 and older:
File > User Preferences > Input: Make sure the search bar is set to 'name' and search for 'extrude'. Under 'Mesh', there is the option 'Extrude and Move on Normals'. Expand that setting and change view3d.edit_mesh_extrude_move_normal to mesh.extrude_region_move. Click 'Save user settings' at the bottom of the window.
You can reset this value by clicking 'Restore' to the right of 'Mesh' in this same window if required.

Blender 2.80:
Edit > Preferences > Keymap: Make sure the search bar is set to 'name' and search for 'Extrude'. Expand the option and change view3d.edit_mesh_extrude_move_normal to mesh.extrude_region_move.
You can reset this value by clicking 'Restore' to the right of 'Mesh' in this same window if required.

$\endgroup$
  • $\begingroup$ It is certainly locked to set the y-axis to 0, it also does this when I try to move a vertice. I tried all different transformation orientations, nothing helped. I tried disabling axes using the corrosponding key, but it resolve my issue (yes I tried all). For Reference I am however doing this in really small dimensions, maybe that does cause this? $\endgroup$ – Y.S Nov 19 at 11:27
  • 1
    $\begingroup$ Could you perhaps send your blend file so I can have a look at the issue? I've tried to replicate your problem but so far I can't seem to find the issue. $\endgroup$ – asoftbird Nov 19 at 11:36
  • 1
    $\begingroup$ I had snap merge for my mirror-tool, but even tho I deactivated it, it seems to be applyed to some vertices, it got a little better after I scaled my mesh using factor 4. $\endgroup$ – Y.S Nov 19 at 14:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.