2
$\begingroup$

Alrighty. I've searched all over the place and even put in a couple of requests from every deity I could think of, but nothing on my issue. So, I'm messing around with making up volumetric light cones for spotlights in Cycles for a project. I've got all of the parts set up and in scene. I start rendering and I get some odd results. With GPU Compute and GPU+CPU I get wicked amounts of noise inside the cones. As if the density of the scatter isn't high enough. Then I try CPU only, it comes out smooth as butter. Now I'm running a 9900k 32GB RAM and an RTX 2080 on the current stable release of 2.80. I just can't figure it out. I mean, I can handle just using my CPU and eating the much longer render times, but I'd much rather use the full power of my rig and get the same if not better results. I'll put up some pics for examples of what I've got going on.CPU only render.  Nice and clean. ish.

GPU only render.  Not so clean.

$\endgroup$
  • 1
    $\begingroup$ Please edit the question and give it an informative title. It's best to form it as a clear question that tells people looking through questions what your problem is about. It would improve your chances of getting a good answer sooner. So you are using the exact same render settings and switching between CPU and GPU Compute only on the official 2.80 release? $\endgroup$ – Martynas Žiemys Nov 19 at 6:11
  • 1
    $\begingroup$ It seems I can replicate the issue with a simple scene with GTX970 and i72600K. It seems it is a bug. It should be reported to the bug tracker. If you report it, could you share the link to the report? $\endgroup$ – Martynas Žiemys Nov 19 at 6:24
  • 2
    $\begingroup$ Looks like a difference in the sampling approach: mobile.twitter.com/stefan_3d/status/1123292775850680321 $\endgroup$ – Robert Gützkow Nov 19 at 8:11
  • 2
    $\begingroup$ @RobertGützkow , could you maybe post this nicely formed as a full answer? I think this one is important to have fully answered for others to be able to find it. $\endgroup$ – Martynas Žiemys Nov 19 at 13:41
  • 1
    $\begingroup$ @JBJB2495, I hope you don't mind me changing the title. It will be easier for others to find this. $\endgroup$ – Martynas Žiemys Nov 19 at 13:45
3
$\begingroup$

The following answer is based on a Twitter thread by Stefan Werner.

Volumetric rendering on the CPU can be less noisy with fewer samples, because Cycles uses equi-angular sampling. This importance sampling technique by C. Kulla and M. Fajardo is currently not implemented for GPU rendering.

The slides from the Eurographics Symposium on Rendering 2012 may help to understand the paper.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.