1
$\begingroup$

I've been trying to set up a cell shader and have gotten to the part of editing the normals to make the shadows smooth, where I run into this problem. It's a fairly simple setup otherwise, with an emission being fed into a shader to RGB with that going into a color ramp and a solidify modifier being used to create an inverted hull outline.

When the mirror and the solidify modifier are active, there are choppy artifacts as depicted here.Image displaying nodes, modifiers, and rendered view of mesh,

As can be seen in the lower half of the image, it is nice and smooth if both modifiers are turned off. If either one is on, the nasty shadows are present in subtly different forms. Applying the modifiers and trying again has had zero influence on how it looks. I've noticed that along the midline the normals seem to be warped slightly to the right with solidify only and bent down with only mirror, but there are differences in shadows even in other areas when either modifier is on and no visible normal differences.

I can take additional pictures if it helps.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.