5
$\begingroup$

I have a character I need to scale for different scenes. I can't get the edited particle hair length/direction to scale with the mesh. It is at least emitting from the same location. I've tried disconnecting the hair and applying scale on the mesh then re-attaching the hair but it doesn't make a difference.

Using the disconnect method seemed to work for edited hair on a cube with 'quick fur' attached but doesn't for my finished/rigged character.

$\endgroup$
  • $\begingroup$ But what if you edited your hair in Particle edit mode and your Hair length is greyed out ? $\endgroup$ – ChameleonScales May 9 '16 at 16:10
3
$\begingroup$

The easiest way would be to use Drivers.

Select your character, and, in the Properties panel, switch to the Particle System tab; At the top, there's a Hair Length field - press RMB (Right Click) and select Add Driver.

Now, switch to the Graph Editor (you could switch a Window to this, but it's easier, from the Default Screen Layout, to double press Ctrl + Left Arrow or to go to the Header and click besides "Default" and choose Animation), set type to Drivers, press N and select your driver from the left side. Select your objects name on the Obj field, then set the type to either X, Y or Z scale. set the Expression to be scale * var, where scale is the Hair Length and var is the variable you just setup.

Now, when you scale your object up, the hair will scale properly.

$\endgroup$
1
$\begingroup$

I had the same problem a few years ago so I had seen this post, now I know a better way to fix scaling.

1.Make an empty and make the Empty the Parent to your object

2.Then scaling the empty will scale the object and also the particles

It even ate lesser memory as I could hide the hairs while editing the scene

$\endgroup$
  • $\begingroup$ This does not work (2.79) $\endgroup$ – Logic1 Jul 6 at 16:40
0
$\begingroup$

The idea of drivers is good, but doesn't work on all hairs: I experienced that scaling up the hair length is sometimes not enough. Other hair effects (especially on children) must be scaled separatedly and it can get complicated (like on the Uniform setting of the children).

Instead, convert the particles to a mesh in the modifiers tab. That works good for scaling but is a performance/memory issue on bigger hair amounts and you should back up the particle system for changes in the hair.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.