1
$\begingroup$

I know that I can use default HDRI maps in Rendered mode in Blender right now, but the problem is when I wan to render the image by F12 (or render movie), my settings are changed to use "scene world". Is there a hidden button somewhere in rendering tab or somewhere else? If I have HDRI correct in rendered mode, why I can't have the same result after F12 render?

$\endgroup$
  • 1
    $\begingroup$ I must admit... I re read your question 20 times at least, and yet, I couldn't grasp what you are asking. What results are you getting when rendering ? Post your blend file, we will be able to answer, hopefully... $\endgroup$ – user83425 Nov 18 '19 at 1:24
  • $\begingroup$ I think this is what you’re asking for youtu.be/eMKST_ddg6s check out 3:40 $\endgroup$ – Alejandro Nevárez Lucio Nov 18 '19 at 7:27
  • $\begingroup$ This is why I asked, because in viewport everything is correct (as it is in the video you posted), but after rendering, Blender ignores this setting, and uses node-based settings. $\endgroup$ – user53826 Nov 18 '19 at 23:19
10
$\begingroup$

This is possible, but at the time of writing it's not a one click solution.

First you need to setup your world to use an environment texture and then load the same HDRI that is used in Look Dev mode. The HDRI can be setup either in the World tab or in the Shader Editor using nodes.

Blender 2.80

World tab 2.80 Shader editor 2.80

Blender 2.81 and later

World tab 2.81 Shader editor 2.81

The HDRIs can be found in Blender's installation directory:

[Install dir]/2.80/datafiles/studiolights/world

In Blender 2.81 you can use the same HDRI from Material Preview mode (formerly called Look Dev) for lighting in the Rendered preview mode in the viewport. Switch to the Rendered mode by clicking on its icon, then open the Viewport Shading options and disable Scene World to ignore the settings from the World tab. One of the HDRI presets can then be selected.

Rendered Mode Viewport Shading

However for the actual rendering you will still need to set it up as described above. In case you've already done that, the Viewport Shading options can be left at their default values with Scene World enabled.

| improve this answer | |
$\endgroup$
  • $\begingroup$ I am using blender 2.81. This works, but how do I hide the hdri image in the background? $\endgroup$ – MVTC Feb 6 at 8:17
  • 1
    $\begingroup$ @MVTC In the Render Properties open the Film tab and check the Transparent option. $\endgroup$ – Robert Gützkow Feb 6 at 10:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.