2
$\begingroup$

Telugu font types with .ttf formatted files are NOT displayed under fonts section of Blender 2.8, Any additional plug-in required or is it an issue?

enter image description here

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ Are you trying to select the font for a text object or for the interface in the preferences? Both work for me using this version of the Dhurjati font. $\endgroup$ – Robert Gützkow Nov 17 at 17:06
  • $\begingroup$ I am trying to select the font for a text object, Font Dhurjati is not visible for me in the Blender font window, where the font is already available in the Windows fonts folder. $\endgroup$ – djavvadi Nov 17 at 17:09
  • $\begingroup$ Perhaps the actual font file isn't called Dhurjati.ttf and therefore doesn't appear after Curlz when sorted in alphabetical order? $\endgroup$ – Robert Gützkow Nov 17 at 17:14
  • 1
    $\begingroup$ No, I checked the properties. It is .ttf file only. I updated the screenshot in the question. $\endgroup$ – djavvadi Nov 17 at 17:24
4
$\begingroup$

It seems that your font file is missing the file extension. While Windows knows that it's a TrueType font, Blender simply filters files by their file extension. Since this particular file doesn't have one, it isn't displayed in the file browser. Add the .ttf file extension to the file name and it should work properly.

Alternatively you can temporarily disable the file extension filter in Blender and the file will be visible as well.

Blender 2.80:

File filter 2.80


Blender 2.81 and later:

File filter 2.81


There may be another reason why you don't find your font file in C:\Windows\Fonts. There are two option for installing fonts, you can either Install it (only for your user) or Install for all users. In the latter case it installs the file as expected into C:\Windows\Fonts, however in the former case it will be placed into C:\Users\[your username]\AppData\Local\Microsoft\Windows\Fonts.

enter image description here Image source: Announcing Windows 10 Insider Preview Build 17704

The Windows Explorer will list all fonts when looking at C:\Windows\Fonts, including those that were installed for your user only. Therefore it's necessary to check where the file is actually stored. The easiest way to find the path is by opening the file's properties. With the file selected, right-click on it to open the context menu and select Properties. The General tab contains the Location property, which is the path to the file.

$\endgroup$
  • $\begingroup$ I disabled the filter, now I could see some files with .ttf files in the explorer except the font I needed. $\endgroup$ – djavvadi Nov 17 at 18:05
  • $\begingroup$ Alright. Press WIN + R, type cmd and press enter. In the command line window that opens up, type cd C:\Windows\Fonts and press enter. Once in the font directory type dir dhurjati* and press enter. Does it find the file? $\endgroup$ – Robert Gützkow Nov 17 at 18:16
  • $\begingroup$ I think I did the same. If you see the screenshot in the question. $\endgroup$ – djavvadi Nov 17 at 18:26
  • $\begingroup$ @djavvadi no it's not the same. The reason why I asked you is because Windows allows you to install fonts for your user only. In that case it will be displayed by the Windows Explorer when navigating to C:\Windows\Fonts, however the font file isn't actually stored there. Instead it's actually in C:\Users\[your username]\AppData\Local\Microsoft\Windows\Fonts. If you list the files in the command line you would see that the file isn't stored in C:\Windows\Fonts. The file location can be identified through its Properties. $\endgroup$ – Robert Gützkow Nov 21 at 18:52
  • $\begingroup$ Yes, you are right, I realized after my comment earlier. I will configure the fonts folder to the desired location in blender and try again. Thanks a lot for your time and suggestions. $\endgroup$ – djavvadi Nov 21 at 19:26
0
$\begingroup$

first search font in blender, switch to folder windows/fonts, select the font there, and drag and drop in into the blender-folder; it went to fast but the message was something like font installed below 'user/...`' and that's why blender doesn't find it

$\endgroup$
  • 1
    $\begingroup$ This is likely the reason, which is why I've asked them to check the content of the directory from the command line (see comment from Nov 17). $\endgroup$ – Robert Gützkow Nov 21 at 11:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.