0
$\begingroup$

So I've been learning to use Blender and want to render the first and last frame of an animation that I created.

Looking at the documentation, I came up with this command:

blender -b test.blend -f 1,50 -o //Output/test_## -F JPEG -x 1

It runs but ends with error:

Error: Not freed memory blocks: 1, total unfreed memory 0.000351 MB

No images are ever produced. If I run without the -b flag, then Blender opens up and I can find the last frame in the render window.

Not sure what I'm doing wrong, I'm sure it's something silly, but after googling for an hour, figured it was time to ask for help. Is it because I am using PowerShell; is it because I have spaces in the name of my directory?

Any help is appreciated.

Here is the output from the command:

Blender 2.80 (sub 75) (hash f6cb5f54494e built 2019-07-29 09:44 AM)
Read prefs: C:\Users\ErMo\AppData\Roaming\Blender Foundation\Blender\2.80\config\userpref.blend
found bundled python: C:\Program Files\Blender Foundation\Blender\2.80\python
Read blend: C:\Users\ErMo\Test\test.blend
Fra:1 Mem:192.91M (0.00M, Peak 289.83M) | Time:00:01.69 | Syncing Camera
Fra:1 Mem:192.91M (0.00M, Peak 289.83M) | Time:00:01.70 | Syncing Human_BaseMesh_Mesh
Fra:1 Mem:193.92M (0.00M, Peak 289.83M) | Time:00:04.16 | Syncing rig
Fra:1 Mem:193.92M (0.00M, Peak 289.83M) | Time:00:04.16 | Syncing Armature
Fra:1 Mem:193.92M (0.00M, Peak 289.83M) | Time:00:04.16 | Syncing metarig
Fra:1 Mem:193.92M (0.00M, Peak 289.83M) | Time:00:04.16 | Syncing Plane
Fra:1 Mem:194.34M (0.00M, Peak 289.83M) | Time:00:06.75 | Syncing Plane.001
Fra:1 Mem:194.79M (0.00M, Peak 289.83M) | Time:00:10.37 | Syncing Curve
Fra:1 Mem:194.80M (0.00M, Peak 289.83M) | Time:00:10.80 | Syncing Curve.005
Fra:1 Mem:194.81M (0.00M, Peak 289.83M) | Time:00:10.80 | Syncing Curve.001
Fra:1 Mem:194.81M (0.00M, Peak 289.83M) | Time:00:10.80 | Syncing Curve.002
Fra:1 Mem:194.83M (0.00M, Peak 289.83M) | Time:00:10.81 | Syncing Curve.003
Fra:1 Mem:194.87M (0.00M, Peak 289.83M) | Time:00:10.81 | Syncing Curve.004
Fra:1 Mem:194.92M (0.00M, Peak 289.83M) | Time:00:10.86 | Rendering 1 / 64 samples
Fra:1 Mem:194.32M (0.00M, Peak 289.83M) | Time:00:32.19 | Rendering 26 / 64 samples
Fra:1 Mem:194.32M (0.00M, Peak 289.83M) | Time:00:53.33 | Rendering 51 / 64 samples
Fra:1 Mem:194.32M (0.00M, Peak 289.83M) | Time:01:04.31 | Rendering 64 / 64 samples
Fra:1 Mem:145.65M (0.00M, Peak 289.83M) | Time:01:05.21 | Sce: Scene Ve:0 Fa:0 La:0
Append frame 1
 Time: 01:05.85 (Saving: 00:00.63)

Fra:50 Mem:194.11M (0.00M, Peak 289.83M) | Time:00:00.03 | Syncing Camera
Fra:50 Mem:194.11M (0.00M, Peak 289.83M) | Time:00:00.03 | Syncing Human_BaseMesh_Mesh
Fra:50 Mem:194.73M (0.00M, Peak 289.83M) | Time:00:00.04 | Syncing rig
Fra:50 Mem:194.73M (0.00M, Peak 289.83M) | Time:00:00.04 | Syncing Armature
Fra:50 Mem:194.73M (0.00M, Peak 289.83M) | Time:00:00.04 | Syncing metarig
Fra:50 Mem:194.73M (0.00M, Peak 289.83M) | Time:00:00.04 | Syncing Plane
Fra:50 Mem:194.77M (0.00M, Peak 289.83M) | Time:00:00.05 | Syncing Plane.001
Fra:50 Mem:194.82M (0.00M, Peak 289.83M) | Time:00:00.05 | Syncing Curve
Fra:50 Mem:194.83M (0.00M, Peak 289.83M) | Time:00:00.05 | Syncing Curve.005
Fra:50 Mem:194.83M (0.00M, Peak 289.83M) | Time:00:00.05 | Syncing Curve.001
Fra:50 Mem:194.83M (0.00M, Peak 289.83M) | Time:00:00.06 | Syncing Curve.002
Fra:50 Mem:194.86M (0.00M, Peak 289.83M) | Time:00:00.06 | Syncing Curve.003
Fra:50 Mem:194.89M (0.00M, Peak 289.83M) | Time:00:00.06 | Syncing Curve.004
Fra:50 Mem:194.94M (0.00M, Peak 289.83M) | Time:00:00.07 | Rendering 1 / 64 samples
Fra:50 Mem:194.34M (0.00M, Peak 289.83M) | Time:00:22.38 | Rendering 26 / 64 samples
Fra:50 Mem:194.34M (0.00M, Peak 289.83M) | Time:00:43.49 | Rendering 51 / 64 samples
Fra:50 Mem:194.34M (0.00M, Peak 289.83M) | Time:00:54.49 | Rendering 64 / 64 samples
Fra:50 Mem:145.67M (0.00M, Peak 289.83M) | Time:00:55.39 | Sce: Scene Ve:0 Fa:0 La:0
Append frame 50
 Time: 00:55.62 (Saving: 00:00.23)

Error: Not freed memory blocks: 1, total unfreed memory 0.000351 MB

Blender quit

Thanks again.

$\endgroup$
3
  • $\begingroup$ may be check this $\endgroup$
    – Yash
    Nov 16 '19 at 8:03
  • 1
    $\begingroup$ The error message indicates that you're encountering a bug in Blender. Please report it on the bug tracker (in Blender: Help > Report a bug) and attach your .blend file to it. Your command should work, although the -f 1,50 should be the last flag since otherwise the rendering is started before the output path and file extension are set. Blender's CLI cares about the order of the flags. $\endgroup$
    – Robert Gützkow
    Nov 16 '19 at 22:20
  • $\begingroup$ Yes this works. Knew it had to be something like this, can't remember where I saw an example that had the flags in the order I posted (I copied and pasted, and then added the path flags). I still get the exact same error though, but I guess it doesn't matter since I get my rendered frames now. Thanks! $\endgroup$
    – ErMo
    Nov 18 '19 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.