I have tried to texture an orange with the shader editor after uwrapping the object, and I got this strange trace on the mesh:

enter image description here

I want to make it disappear but I didn't find any issue. I have tried merge by distance but it doesn't work.

This is the link of the .blend:

  • $\begingroup$ Perhaps flip normals? Could you please share your file? blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Nov 15 '19 at 11:06
  • $\begingroup$ I have already tried flip normals but it doesn't change anything,how to share the file? $\endgroup$ – Antalia Ariel Nov 15 '19 at 11:22
  • $\begingroup$ copy the address of this page, click on the link and paste the address in the field where it asked, upload your file $\endgroup$ – moonboots Nov 15 '19 at 11:24
  • 1
    $\begingroup$ What version of Blender are you using, @AntaliaAriel? I opened your file in Blender 2.80, but the line in your picture is not present for me. $\endgroup$ – NeverConvex Nov 15 '19 at 23:03
  • $\begingroup$ He is using Ver. 2.80.75... Maybe it is a graphic card issue (bad driver, or something ?) $\endgroup$ – user83425 Nov 15 '19 at 23:17

Usually, its not necessary to do UV unwrap for procedural textures. Try setting the texture coordinate node to OBJECT and see if it still shows that trace.

Edit : I downloaded your Blend file, but there is no line appearing in the viewport.enter image description here

Not even in the render (Cycles) : enter image description here

(The light is a bit weird btw)

  • $\begingroup$ I think we should always UV unwrap for procedural textures. The UV map is additional information beside the vertices data. Those primitive object we added include a default UV map for conveniences. Once you change those vertices, the UV need to be rearrange for sure. $\endgroup$ – Hikariztw Nov 16 '19 at 0:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.