I would like to control Blender on a remote server (Ubuntu, local network) from my Notebook (Windows 7).

Until now I evaluated the following configurations, none of them works satisfactorily.

1 VNC (followed this tutorial)

Result: Applications like Firefox, Libre-Office work but Blender's UI is rendered incomplete and unusable.

enter image description here

2 MobaXTerm

MobaXTerm supports SSH and comes with its own X-Server: Again firefox and other apps work but Blender crashes:

$ blender
Color management: using fallback mode for management
connect failed: No such file or directory
X Error of failed request:  GLXBadRenderRequest
  Major opcode of failed request:  146 (GLX)
  Minor opcode of failed request:  1 (X_GLXRender)
  Serial number of failed request:  154
  Current serial number in output stream:  179

3 Run Ubuntu under VMWare and Tunnel X through SSH

Blender starts flawless but the connection (100MBit/s) is so slow that it takes 2-3s to open a menu. Instructions on AskUbuntu

Is there an alternative to the methods I tried?


The MobaXterm settings that worked for me:

enter image description here

  • $\begingroup$ Would an NX session work? $\endgroup$ – ajwood Sep 13 '14 at 16:49
  • $\begingroup$ There was decent local X server for windows, tried it couple years ago: Xming. Never tested any heavier applications though. $\endgroup$ – kilbee Sep 13 '14 at 18:43

The latest version of MobaXterm works great with Blender! I just had to check the "Hardware OpenGL acceleration" in order to make it work (under "Settings" --> "Configuration" --> "X11" tab.

I started a SSH connection with compression enabled in order to lower bandwidth usage and started Blender which now works correctly.

I am running the latest free version of MobaXterm from http://mobaxterm.mobatek.net and my Windows computer has a nVidia Geforce GT640 with the latest nVidia drivers.

I hope this helps!

| improve this answer | |
  • $\begingroup$ Thanks, after setting the X11 server display mode to "Rootless" it now works. $\endgroup$ – stacker Sep 13 '14 at 20:02

I currently use Splashtop it's free for personal use in your local network. You can also transfer sound to your local device and stream videos. The mouse is a bit laggy but modeling works. Due to the mouse lag it's not suitable for games.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.