2
$\begingroup$

I'm importing a mesh i made into unity before exporting I always rotate it by -90 degrees in the X axis, then set the orientation to Y forward and Z up so when the object is imported to unity the object's orientation will fit into unity's native orientation, However whenever I do this after being importing to Unity the mesh is inside out or transparent but When I don't do the rotation of -90 on the X axis the mesh loads correctly aside from the orientation of the mesh being incorrect and it doesn't match unity's native orientation, i really can't figure it out this is the first time I'm having this problem My setup usually works in the meshes i import to unity but this time i got this problem.

enter image description here enter image description here

$\endgroup$
  • 2
    $\begingroup$ Please use fewer images on your post, if they aren't absolutely necessary; Also, cut them so that only essential parts are visible. Another thing is, a proper grammar, uppercase letters (where they should) will make the post more readable and look better. $\endgroup$ – someonewithpc Sep 13 '14 at 12:36
3
$\begingroup$

When you import into Unity, there is an option to calculate normals, instead of importing them. Have you tried that?

Blender also has an option to show surface normals, as well as recalculate normals to face in or out of the mesh.

$\endgroup$
  • $\begingroup$ i have already solved it and yes you are right the problem is with the normals, all i had to do was to flip it. and it worked. so my question now is how do i mark this post as solved? $\endgroup$ – Woo Sep 14 '14 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.