35
$\begingroup$

When I make an animation, it always starts out slow, then speeds up, then slows down at the end. I cannot figure out how to fix this.

$\endgroup$
43
$\begingroup$

Simply go to the Animation Screen Layout:

enter image description here

Now select Channel > Extrapolation Mode > Linear Extrapolation (shortcut Shift + E):

enter image description here

And that should fix it for you.

If you look at the Graph Editor before doing this, you will see:

enter image description here

The beginning and end of the curve are levelled out, this is what gives you the slowing down effect. It is called a Bezier function. When you choose 'Linear Extrapolation' it makes the curve a straight line:

enter image description here

The straight line is extended in both directions giving you continued animation, whereby if you choose Interpolation, Key > Interpolation Mode > Linear (shortcut T):

enter image description here

What starts off as curves...

enter image description here

...results in straight lines between keyframes with no extension beyond:

enter image description here

$\endgroup$
  • 4
    $\begingroup$ Just as an addendum, you can change the extrapolation mode by pressing T on your keyboard. $\endgroup$ – CharlesL Jul 1 '13 at 23:15
  • 4
    $\begingroup$ Hitting T changes interpolation mode. Extrapolation mode means how the motion continues outside the keyframes. $\endgroup$ – hjaarnio Jul 2 '13 at 4:54
8
$\begingroup$

Go to the animation layout, and in the F-curve editor you can either hit T, to set the channel interpolation mode to linear, which affects the whole channel you have selected in the menu on the left side, or hit V to set the selected keyframe handles to vector mode. With setting single keyframe handles you have the possibility to use both kinds of interpolations.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.